Downgrade sangoma-pbx-2002-2.sng7.noarch to the previous version

Yesterday, I applied system update that updated sangoma-pbx-2002-2.sng7.noarch and google-cloud-sdk to the most recent versions. This morning I got a message from the Rootkit Hunter that my tftp was enabled. I reviewed rkhunter.log from the day before and there were no messages. I do not do provisioning and I believe that I have set provisioning services off. I wonder if sangoma-pbx-2002-2.sng7.noarch has caused tftp to turn on. I would like to test it by downgrading then upgrading again.

  • Does anyone know how to downgrade sangoma-pbx-2002-2.sng7.noarch to the previous version?
1 Like
yum downgrade sangoma-pbx

Thank you @lgaetz. I did yum downgrade sangoma-pbx, checked ftp = disabled then yum update and ftp stayed disabled.

I also started VM machine from snapshot prior to yesterday’s update and did yum update and checked the tftp and it was disabled before and after the update. I hope it is just an overlooked or a mistake from my end when I was at the GUI but I prefer to be safe than sorry. Thanks again.

I have tested as well, and did not see the issue when using the GUI to disable tftp. I have an internal ticket on this if anyone has details, or is able to reliably reproduce, but as things look now this is not an issue.

So far I have not seen any systems where tftp was disabled and got re-enabled, however it did re-enable mongodb on several servers where I know it had been disabled. Any idea why? I thought this was only used by the now-deprecated XMPP. Is it needed for something else?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.