Double VM after set IVR to retn after VM

When I call an extension during the IVR announcement and after I leave a message, press # and 1 the system hangs up (as it should).
When I check, on the IVR screen
"Return to IVR after VM"
after I leave a message, press # 1 to accept, it repeats “Extension unavailable” and I am asked to leave a message again, then I am returned to voicemail.

Any idea why?

Distro Installed 8/2013
PBX Firmware: 1.813.210.58-1
PBX Service Pack:

When I set my IVR to have an option (for testing) to go straight to voicemail, if I call in and leave a message, then press # to complete, it tells me “You have exited the voicemail system and will be transferred back to the previous menu.”

I do not have anything that says press 1 to disconnect - it simply says you may hang up to disconnect.

However, if you are dialing an extension, you are not inside the IVR - so not sure if that makes a difference.

Try setting one of your IVR options to destination Voicemail and a Mailbox. Dial that option (not extension) and see if after the message it returns to IVR. If someone dials an extension vs. option of IVR, it may handle the call differently and not use the IVR rules but instead Extension rules.

Hope that makes sense!

I set option 6 of the IVR to go to my extension (101) VM “busy”.
Return to IVR after VM option in the IVR is unchecked
After leaving a message, press # when finished, then 1 to accept this message.
"Your message has been saved…"
System says “Goodbye”, as it should

Return to IVR after VM option in the IVR is checked
Leave Message, press #, 1 to accept.
"You have exited the Voicemail system…"
Returns to the IVR (as it should)

During the IVR, type 101 - my phone rings. I don’t answer
The person at 101 is unavailable…"
Leave a message, #, 1,
"Your message has been saved…"
The person at 101 is unavailable…"
Leave a message, #, 1,
“Your message has been saved…”
“You have exited the Voicemail system…” Duplicate message.

Because you are dialing an extension, you are leaving the IVR, so it does not return to IVR.

Now, on the IVR screen you can disable “Direct Dial” option so callers cannot dial extensions.

If you want something like extensions to still work on a select basis, you can create options in the IVR for “option” 101 to go to extension 101 - that would keep it inside the IVR.

I changed the IVR option to dial an extension, rather then route to voicemail. When I select the option and it dials my extension, it also doubles the message.

Menu options for each extension is not feasible. Re-entering everyone extension in the IVR is not optimal.

The “Return to IVR after leaving a VM” is a reasonable function. That fact that activating this function causes TWO instances of “Please record your message” is either a quirk in the configuration or a downright “Bug”.
The question of “Why this is happening” – is there an extension-related setting, or a System default?
Or is it just a bug that needs to be reported and dealt with.