Double touchtones sent after FPBX/asterisk/dahdi upgrade

Immediately after updating from * 1.4.19 to 1.4.22, to FPBX 2.5.1, and switching from zaptel to dahdi (Sangoma 200 card for 6 analog lines), users are getting outgoing dtmf keybounce, meaning outside IVR systems are picking up extra key presses. You can hear it on the local phone. Not with every key, but it’s unusual to hit more than three keys without a stuttered double-beep. Short or long key presses don’t help. Long key presses on some keys can result in a machine-gun dtmf. A few keys (1,7,9?) seem more prone to the problem though they may work fine during the same call.

I’ve tried to resolve it by changing from rfc2833 to inband, back & forth with relaxdtmf (before I learned it was an inbound parameter), echocancel, echotraining, playing with tx and rxgain (in the thoughts I might be getting an echo loop), but nothing has helped. It even happens with rxgain & txgain down to -5, echocancel disabled, and inband dtmf. You can barely hear it but it’s still doing it.

The system is 1.4.22 on CentOS 5.2. The phones are a mix of Snom 3x0s, and DTMF via info is OFF.

Does this sound familiar to anyone? I did bump into a similar report on a digium list but nothing about a resolution.

Okay, here’s the post regarding the bug:

I also noticed a post where someone said they had fixed the problem by adding a ‘T’ to their dial command options. That didn’t do anything here, but then I tried it in outbound Dial command options (hey, it’s late) and voila! No more repeated tones! I’m not entirely confident yet but it’s time for the users to bang on it for a day.