Double Tones

I thought I had everything up and working on my server, but today we just ran into a problem where we couldn’t enter a code on a IVR (calling into a conference call, enter the pin). It worked from a cell phone, so the problem is on my end. When entering a code 1234, the remote IVR thinks I entered 11223344.

I have found this post, which is similar, but I don’t think it helps me. It is also 3 years old.

I am running an install from the AsteriskNOW iso, FreePBX Code, Asterisk I am using Cisco 303 phones, and an X-Lite softphone. The problem happens on all.

Thanks for the help. If you think a log would help, let me know and I’ll get it.

What/who are you using for your trunk?

Make sure that your trunk settings contain this line:


If you are using an FXO device for your telephone lines, make sure your DTMF mode is set to the RFC2833 only, and not to both inband and RFC2833.

If this doesn’t work, try another provider.

Thanks. I checked and dtmfmode=rfc2833 is already in there. I don’t see any “inband” in the outgoing or incoming trunk settings. I’m using voipvoip for my provider. (Makes me feel bad for recommending them in the other thread up here. I’ll shoot them an email to see what they say as well.)

Found the solution.

-Cisco 303 phones: In their web admin page (their IP), under Admin-Advanced-SIP there is a setting for “DTMF Relay MIME Type” which is some random value by default. Change this to rfc2388 and it should work.

-XLite: Under preferences -> Advanced -> Uncheck inband (like AdHominem said before, but I didn’t check)