Don't play audio in IVR

good afternoon community your kind help I have a problem with my freepbx, when I load an audio.wav, when I call the ivr extension it doesn’t play the audio, as such the ivr options work to call other extensions.

What does the full log say about the failure?

Please confirm that the file is not just a .wav file, but specifically an 8kHz, mono, 16 bit signed linear (PCM), LSB first ,wav file.

If you direct the DID directly to a local extension, do you get two way audio? Are there examples where the caller does get two way audio?

Is the caller coming in via an ITSP, or are they a remote extension?

yes sorry for the delay I was doing more tests, but it’s still the same if the file I load is a WAV archive, sorry how can I put logs?
I have bidirectional response without problem, the only one that does not work is the audio, nothing is heard.

and the communication is between a remote extension

What’s a WAV archive?

I should have pointed out that Asterisk assumes that files with the uppercase extension .WAV, are .wav type 49 files, i.e. GSM standard rate audio.

If that extension is behind NAT, it may be sending its private address in the SDP. In that case, before Asterisk can send media to it, Asterisk must be configured with symmetric media (comedia in the obsolete SIP driver) AND the remote device must, successfully, send media to Asterisk, before Asterisk can send to it, as that is how Asterisk learns how to correct the media address.

(Use of ICE, or setting the equivalent of Asterisk’s external media address, at the remote end are other ways that might give a valid media address.)


Hello friend, in the CLI it gives me this error to what I set to the IVR, thanks for your continuous help

attached second photo with the permissions and characteristics of the audio, your help I need urgently

Please use pastebin, pictures are often ignored as a PITA

Is the correct language set? Do the intermediate directories have execute permission?