Does your DISA work? Problem solved

Hello, I have FreePBX 16 and when I try to use DISA, the system does not detect DTMF. Do you have the same problem?

I had not used DISA in quite a while, since 4G/5G coverage in our areas has improved and mobile SIP apps now have consistently good quality. Based on your post, I gave it a try and had no issues with DTMF. However, it didn’t pass the specified caller ID and I’ll report the results of troubleshooting that.

Does inbound DTMF otherwise work on the affected number, for example routing to an IVR, or retrieving voicemails?

If you point a Misc Application to the DISA and call it from a local extension, does that work correctly?

In Settings → Asterisk Logfile Settings → Log Files, you can enable logging DTMF events to the console and/or ‘full’ (the regular Asterisk log file).

What kind of trunk are you calling in on? If not VoIP, provide details, e.g., PRI via Vega gateway. If applicable, you might try changing DTMF Mode for the trunk.

routing to an IVR, or retrieving voicemails?
It is the same problem.
local extension, does that work correctly?
Yes I can do transfer call and conference.
trunk are you calling in on:
The trunk is SIP with Freephoneline

Thank you for your responce.

I solved the problem by changing in the trunk dtmfmode=rfc2833 to dtmfmode=auto
Now my IVR and DISA accept DTMF.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.