Do not work after upgrade from 2.4 to 2.5 with mISDN

Hello co-users,

after an upgrade from 2.4 to 2.5, my freebx runs, but all incoming routes over misdn do not work like before.

calls will be disconnected and caller is hearing a busy tone.

is there any change to do in /etc/asterisk/misdn.conf ? like context or something?

would be great to get some help here.



I don’t work with misdn. But you did a backup before upgrading correct? compare the misdn.conf files between versions would get you that answer quicker then anything else.

  1. You should be checking whether asterisk is loading chan_misdn by inputting ‘help’ to the askerisk CLI and look for misdn… commands.

If they are there go to 2) if not go to 3).

  1. Input ‘misdn show stacks’ to the asterisk CLI. If you see your ports and they are ‘UP’ then check the context setting in /etc/asterisk/misdn.conf

Ok i’ll be honest, it’s getting late for me and i haven’t the head to respond now!

So look at these articals.

Thanx Guys,

i have had some extra lines in extensions_custom.conf for inbound routes.

So i deleted them and it works fine.

Cheers Dennis