Hi, I’m new to FreePBX and having a bit of a problem. 280XXXXX <-- This telephone no. apparently has a Do-Not-Disturb feature activated. It requests you to key in a password. However, whenever we dial that number from our end it will just keep on ringing and you will not even hear the Do-Not-Disturb voicemail setup by the callee. Now, during my troubleshooting, I found out that it happens only on a particular Outbound Route. The other Outbound Route that we use connects just fine and you can hear the Do-not-disturb voicemail. I wonder what’s wrong with this?

I use FreePBX and Asterisk 1.6

Please feel free to ask me for additional info. if more is needed.

The additional info would be

“What version of Asterisk 1.6?” (less recent versions are buggy)

“how are you sending DTMF to that carrier?” (hopefully dtmfmode=? in you trunk settings, they should provide a template)

“Are you using inband DTMF signalling in over a compressed codec?” (this just won’t work and is your problem)

“how effective is each carrier in passing DTMF signaling?” (If they say RFC1833 or auto but the detection is not working, then bitch at them, if the want SIP info then make sure you are using it)

Let’s start there . . . .

Hi Dicko,

Sorry just got back from weekend off. Here are the additional info. you requested:

Asterisk ver.
For the DTMF, it actually goes via the DAHDI Trunks.

As for your question, “Are you using inband DTMF signalling in over a compressed codec?”… Can you tell me where to check this one out? (Sorry, like I said I’m a newbie on this)

Thank you for your help!

If you are using Dahdi and ulaw for US or alaw for most every where else, then you should be good codec wise, they are uncompressed. You might need to tune your rxgain/txgain if you have a wildly imbalanced trunk, you didn’t say what your dahdi trunks are, FXO (analog) or TDM (digital).

That you are using dahdi and more than one outbound route needs clarification, please say why. do the calls both end up going throught the same trunk?

Hi Dicko,

I am indeed using g729, ulaw and alaw. I am using a digital trunk. The other outbound route is something of a fail safe in case the main trunk goes down. The two outbound routes that I have mentioned have different dialing prefix.

“Do the calls both end up going throught the same trunk?” ----> I’ve checked the logs and all calls are going through the main dahdi trunk as expected. No one’s using the fail safe Outbound Route unless there’s a problem with the main trunk.

Below are the values I have for the txgain and rxgain for different configuration files. Are the values optimal or do I need to adjust any of this?

/etc/asterisk/misdn.conf:;txgain: 0

/etc/asterisk/misdn.conf:; default values: rxgain: 0

Well you can’t use g729 on a dahdi trunk, so don’t try. I was under the impression that dahdi would reject that attempt, limit yourself to alaw OR ulaw (not both) depending on the pre-emphasis your local carrier uses.

I would suggest that txgain of 9.0 or rx will overmodulate your trunks to be seriously clipped.

Please get to understand how files are included in the base /etc/asterisk/*.conf files.

Basically why did you set up those gains? almost always unnecessary with tdm, you still neglect to say what your dahdi technology is, random acts of change can spoil your whole day :slight_smile:

I say again they need local tuning to your trunks, google milliwatt testing asterisk or just use your ears on a dahdi_monitor recorded file (the stereo version with a good headset is quite revealing, sometimes we forget good old rational thinking, that test will cost you a dollar at the dollar store if you don’t have a headset)

Hi Dicko,

Thanks for your quick response. Sorry to ask another newbie question again, but how do I make dahdi trunk use ulaw or alaw only? The only setting that I know where I can configure the ulaw/alaw codec is whenever I create an extension as well as when setting up a softphone.

From the config I copied above, the only relevant files there, I believe, are the chan_dahdi_general_custom.conf (RX/TX=9) and chan_dahdi_custom.conf (RX/TX=7). I don’t remember setting up those gains, though. Aren’t they auto-generated?

As for the dahdi technology, I have a Wildcard TE220 (5th Gen)(VPMOCT064).

Thanks for the tip on the tuning. I will do this during afterhours when no one are using the phones as this may probably involve rebooting the dahdi and such.

If you have a genuine Digium card, you can get support directly from them, if you have an “off-shore” clone, then you are on your own, and it probably won’t work correctly :wink:



to reflect

alaw=1-4 # or ulaw=5-36 or whatever

in the right group
feel free to test online, but changing the gains needs at least a reload if not the full monty on asterisk being down, (no not a reboot)

( is always a good resource)