Distro Upgrade 13 to 14


(Andrew) #1

Currently having issues after upgrading from 10.13.66-22 to SNG7 using distro-upgrade following this article on the wiki.

I get HTTP 500 errors when accessing /admin and /ucp. I also have run the ./post_upgrade script referenced in the wiki as well.

See httpd logs below:

[Fri Mar 19 12:57:57.714563 2021] [:error] [pid 1475] [client xxx.xxx.xxx.xxx:53151] PHP Warning:  include_once(/etc/freepbx.conf): failed to open stream: Permission denied in /var/www/html/admin/config.php on line 127
[Fri Mar 19 12:57:57.714666 2021] [:error] [pid 1475] [client xxx.xxx.xxx.xxx:53151] PHP Warning:  include_once(): Failed opening '/etc/freepbx.conf' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/admin/config.php on line 127
[Fri Mar 19 12:57:57.714733 2021] [:error] [pid 1475] [client xxx.xxx.xxx.xxx:53151] PHP Fatal error:  Class 'FreePBX' not found in /var/www/html/admin/config.php on line 137
[Fri Mar 19 12:57:57.714846 2021] [:error] [pid 1475] [client xxx.xxx.xxx.xxx:53151] PHP Warning:  Unknown: open(/var/lib/php/session/sess_sgbm262dfen0ivhu36oni979r2, O_RDWR) failed: Permission denied (13) in Unknown on line 0
[Fri Mar 19 12:57:57.714882 2021] [:error] [pid 1475] [client xxx.xxx.xxx.xxx:53151] PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

I have tried deleting the sessions from /var/lib/php/session and I get the same result. Any help is appreciated.


(TheJames) #2

try running fwconsole chown


(Andrew) #3

Thanks for the suggestion. Same issue after running, logs come up with the same errors as well.


(Andrew) #4

Not sure if this is related but I am receiving the below in asterisk logs:

[2021-03-19 15:15:43] NOTICE[8107]: manager.c:3548 authenticate: 127.0.0.1 failed to authenticate as 'admin'

The secret in /etc/asterisk/manager.conf is different to what is was prior to upgrade, but I changed it to the old secret, ran fwconsole restart but it is still appearing in the logs.

Also, not sure if it means anything but this is the output of my fwconsole restart:

[root@system ~]# fwconsole restart
Running FreePBX shutdown...

Core FastAGI Server is not running
SmartOffice Server is not running
RestApps Server is not running
SangomaConnect Server is not running
UCP Node Server is not running
Chat Server is not running
Zulu Server is not running

In php-asmanager.php line 489:

  fclose(): 110 is not a valid stream resource


restart [-i|--immediate] [--] [<args>]...

[root@system ~]#

(Andrew) #5

So I got past the HTTP errors by yum reinstall httpd - I hope this doesn’t break anything specific to the FreePBX Distro httpd config that I just haven’t noticed yet.

Once complete I could login to FreePBX just fine. Applying config gave me the below error:

exit: 1
Unable to continue. Illegal string offset 'target' in /var/www/html/admin/modules/customappsreg/functions.inc.php on line 59 
#0 /var/www/html/admin/modules/customappsreg/functions.inc.php(59): Whoops\Run-&gt;handleError(2, 'Illegal string ...', '/var/www/html/a...', 59, Array) 
#1 /var/www/html/admin/libraries/usage_registry.functions.php(300): customappsreg_getdestinfo('ivr-1,s,1') 
#2 /var/www/html/admin/libraries/usage_registry.functions.php(351): framework_identify_destinations(Array, Array) 
#3 /var/lib/asterisk/bin/retrieve_conf(819): framework_list_problem_destinations(Array, false) 
#4 {main}

I updated the Custom Application Module and that allowed me to apply config. I guess I’ll just post any other errors I get, though I’m still not sure what part of the upgrade process borked my httpd.


(Andrew) #6

So here’s what’s coming up in the upgrade process from 13 to 14 - this is the /tmp/cmd_temporary_output file:

Updating   : httpd-2.4.6-93.el7.centos.x86_64                         173/586
warning: /etc/httpd/conf/httpd.conf created as /etc/httpd/conf/httpd.conf.rpmnew
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2021-03-22 15:21:11 PDT; 6min ago
     Docs: man:httpd(8)
           man:apachectl(8)
 Main PID: 6551 (code=exited, status=1/FAILURE)

Mar 22 15:21:11 hostname.tld systemd[1]: Starting The Apache HTTP Server...
Mar 22 15:21:11 hostname.tld httpd[6551]: httpd: Syntax error on line 153 of /etc/httpd/conf/httpd.conf: Cannot load modules/mod_authn_alias.so into server: /etc/httpd/modules/mod_authn_alias.so: cannot open shared object file: No such file or directory
Mar 22 15:21:11 hostname.tld systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Mar 22 15:21:11 hostname.tld kill[6553]: kill: cannot find process ""
Mar 22 15:21:11 hostname.tld systemd[1]: httpd.service: control process exited, code=exited status=1
Mar 22 15:21:11 hostname.tld systemd[1]: Failed to start The Apache HTTP Server.
Mar 22 15:21:11 hostname.tld systemd[1]: Unit httpd.service entered failed state.
Mar 22 15:21:11 hostname.tld systemd[1]: httpd.service failed.
Warning: httpd.service changed on disk. Run 'systemctl daemon-reload' to reload units.

After the upgrade completed, I ran systemctl daemon-reload but that didn’t appear to fix anything. Still requires a yum reinstall httpd to resolve. Just thought I would update for posterity.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.


(system) opened #8

(Lorne Gaetz) closed #9

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.