Distro: Password for PBX admin


Just installed the new distro (version on a VM in Citrix XEN and installation went without problems. I was amazed it took longer than expected but it finished without errors.

At this point I only have one problem, I visited the website, filled in passwords and e-mail address and got to the second page (where you can choose ARI, AMI, FOP).

Issue I have here is that I can not login to the AMI with the password I just filled in?

Any suggestions on what to do next?


the AMI password is the Asterisk Manager Password which is completely un-related.

You are right the user/password info is confusing. It’s already in-plan to add tooltips to those fields to explain exactly what they do.

The crux, the user/password is the FreePBX user/password for admin and is also used to set the default ARI user/admin password. The latter can be changed from the Advanced Settings if that were desired. The FOP password is for privileged FOP features. The email is for the local system to email module updates (never leaves the local system, it’s private).

If you can’t login then you mis-typed something or don’t recall what you put in, unless something very odd occurred which I guess is always possible. If need be, you can disable all authentication from the Linux command line, then go in and edit/change/add administrators and then re-enable authentication:

amportal admin auth_none / auth_database

are the commands to disable / enable authentication.

if you are really trying to login to the AMI (manager) it’s not with those credentials. The AMI credentials are randomly generated when the Distro is loaded.

As a general rule, it’s not a good idea to use the ‘FreePBX’ AMI credentials for other applications if that is what you are doing. You can create new credentials for the specific application with the Manager module giving it only the permissions and control that it needs.

If you really need the AMI credentials, you can get them in manager.conf.

Well problem is the PBX Administrator I cannot login to (isnt it called ami?).

Maybe it should be explained in the webinterface installer where to use what password for (especially for new users).
It’s a bit confusing at this time…

Since it is 2.9 I need to look for the password in /etc/asterisk/manager.conf ?
That password is not working. The password in /etc/amportal.conf is also not working.

Well I’m pretty sure I typed it in correctly but as an IT guy I also hear that sentence a lot from my endusers :slight_smile:
It might just be a good idea to do the installation again.

I’ll do it again this weekend and run some tests on XEN to see how it performs. If still unsuccesfull with the login I’ll reply this topic.

Thanks again Philippe!

Tested it this weekend on XEN by installing it 3 times. Colleague of mine installed it 2 times today. We both have the same issue with the passwords and cannot login to the freepbx admin…
I’ll try and change the auth method in amportal.conf


We do not setup any stock password.

Do you see a setup screen the first time you log into the GUI. On this screen you setup a admin username and you type the password twice for the admin user. This is the username and password you use to log into FreePBX Admin GUI.

Thanks for the help, we found the ‘problem’.
We tried it using Internet Explorer 9 with no luck but when we switched to Safari 5 we could login without problems. Don’t exactly know what caused this but will look in to it.

Well we have a domain controlled environment. Tested it on a domain machine with policies and there it didn’t work. Just tested it on a machine without policies and everything works fine there. Sorry for inconvenience.

Well that is odd. I just tested on my windows machine with IE and it worked fine. Glad you figured it out.