Distro cannot install on new HP DL385-G7

I went through the installation of 2.10 beta 2 and all seems well. Then upon reboot the system cannot find the partitions. The server has hardware raid and I think I read somewhere that it can cause problems for the distro. Sorry I don’t have a specific error message but I thought maybe someone else had run into this too. Any ideas? Otherwise I will try the install again to get the actual error message.

Did you do the install off of a CDRom?

I believe so. I really can’t remember as it was 3-4 weeks ago.

This was the 64 bit version if it matters.

Sounds like you installed off a usb drive

Maybe… is that not allowed?

No since it mounts the USB as a hard drive.

Will an external usb cdrom work?

Should but have not tried it before

It will work. I have installed the distro from a USB CD/DVD drive many, many times.

Install worked with usb cdrom drive. It would be very nice if the install worked from a usb stick though. However I appreciate the help very much!