Distro and PJSIP: No Audio

I have been messing around with the latest version of distro 14, and have not had this issue with 13.
Upon creating PJSIP extension, I get no audio at all. With 13, all I did was create the extension , plugged in a telephone and I was good.

Now I am getting no audio with 14.

Any idea why?

Update: I swapped ports for chan_sip and PJSIP and started getting audio for PJSIP. Seriously, what is going on with this?

In PJSIP settings page, set allow reload to yes. This should fix these issues going forward.

When you changed the ports you just restarted asterisk which is what made it work…

Your own configuration/network. Nothing to do with FreePBX. You changing the ports proves this.

I disagree on this one.
I had it a few times, when creating a new PJSIP extension, (on a system that has ChanSIP as well) I had no audio until I restarted asterisk, or enabled allow reload as mentioned.

Apparently, this issue was discussed here already.

You do realize that audio goes over RTP right? It does not travel over port 5060 or whatever port you have setup for PJSIP/chan_sip. If you registered over PJSIP, which you would have, then the PJSIP port is irrelevant because it already worked. The PJSIP port is for signaling, the RTP ports (which you aren’t changing) are for audio. If you were unable to register then sure, the PJSIP port didn’t work. But you’ve both said you made calls and there was no audio. Therefore PJSIP signaling port is working.

Considering PJSIP’s default is 5060, some providers block this port. Changing it to anything else would make it work. But then again you were already registered.

The issue here is not the port PJSIP is on, rather sometimes else. (happens to be that when OP changed port it started working - since I assume that he restarted asterisk, which is required after changing port)
And the audio issues are internal calls, echo tests etc.

So I guess this is unrelated to the port PJSIP is on, See link I posted.

I see. It’s not related to pjsip port at all. It’s related to external contact address. Which is not written to the transports until you save and we also have allow reload disabled at this time. Therefore the transports will not update.

What I am saying is when setting up an extension on the default ports of 5060 PJSIP, and 5160 or chan_sip, I was getting no audio on PJSIP. To test chan_sipm I also set up an extension for chan_sip on port 5160.

chan_sip extension audio was functioning as expected, but for PJSIP, no audio could be heard.

This is setting up new Sangoma OS w/FreePBX 14 three times now.

After swapping the default ports with chan_sip to port 5060, and PJSIP to 5160, I am now getting audio.

I will try the " Allow Reload = Yes" in PJSIP Advanced settings in discussed in that thread on a new install tomorrow, and let you all know.


@GeekBoy do you have some time to play around?

Can you set PJSIP on 5060, restart asterisk, create the extension, set allow reload to test and perform a echo test by dialing *43

Please report back.


EDIT: I see your edit. Thanks

I will get it tomorrow. Thanks

1 Like

I have seen issues when converting extensions from chansip to pjsip or back. Nothing to do with audio but
qualify messages would be sent to the wrong port resulting in 404 not found or invite headers would be screwed up.
Asterisk restart would fix the problems.

The issue is as described above thanks to @PitzKey for pointing this out. It needs a bug report to be opened against it to be fixed.

Doing the suggested change works out.,

Thanks all.

This is now fixed: https://issues.freepbx.org/browse/FREEPBX-18165


That was quick. Thanks for the quick turn around.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.