Distro (or won't load on supermicro?

I’ve tried different CDROM drives, different CDs, (and 4) and even putting the iso on a thumbdrive* and I can’t get the system to load the netloader. I tried the same with a Compaq DL380G3 with the same results.

    • the thumbdrive ends up with a kickstart problem, not the same as the ISOLINUX failing to load with the systems above. (it has an issue with sdb)

Is there a super-excellent way to gather usable information so this can be reviewed? What info, BIOS tricks, or things should I try? I could roll a video of the experience.

Peter - This is most odd as I have the distro running on two DL360 G4’s and we are on our fifth Supermicro Dual Core Atom box.

I cetainly am not doing anything special.

Wish I had more constructive information other than empirical evidence to offer you.

When are you coming back to Cleveland?

Hi Scott!

The s’micro boxes are semi-beefy systems we bought through Tony (dual chip, etc) a year ago. Maybe I can rip a video of it to show what is/isn’t happening when it tries to load Stage 1.

This gets me thinking – what if I burn the CD at a slower speed? I’ll try that first…

PS. I left an Airport Express in my room. Someone in Cleveland is just a wee bit happer, I hope.


First system is the guy I’d really like loaded. (I’ve tried two CDs as well as an external CD drive.)

The system’s specs should be readable in the video, but it has dual #5506 2.13Ghz procs and 4G RAM (X8DTU mobo?). I’m using the onboard RAID (RAID1 + spare).

Second system is a beater – just wanted to demonstrate that the disc is good…

So I took another run at this.

The plan was to roll to this system Tuesday night. That may be in jeopardy.

Loading from ISO really seems to not be an option. I took the iso and splatted it on a USB flash. Going this route I’m able to get up to the first menu, the system gets an IP config and then it pulls down stage2.img nicely. As it starts to lay out for the install it eventually blows up here.

At this point I know two things: the kernel doesn’t have the driver for the on-board Intel RAID (config’d for RAID1) and my reading of the kickstart is that its not discriminate to what drives is starts using. Here is what the kickstart is working with:

When I’ve written kickstart code like this I only used drives that were the same size as the first one after sort -k 2,2n and such. Once iterating over the drives, quit when the size no longer matches.

The other screens, if they’re useful:

At this point it’s eaten its young and the USB flash drive has to be rebuilt.

I’m thinking about rewriting the kickstart’s logic for picking over the harddrives. Maybe I turn off the RAID on the mobo and just go with the software raid? Other ideas?

Also, for this round I’ve updated to…

In the end I fully abandoned burning the image to a CD and just used a USB drive.

The process to make this happen started with pulling down the ISO to a linux system. Then I cribbed the instructions from the http://wiki.centos.org/HowTos/InstallFromUSBkey Centos Wiki.

if you’re skilled and know what the device actually is (using sdg in my examples) the commands are:

fdisk /dev/sdg d # delete existing partition - repeat as necessary n # new partition p # primary 1 # partition number <enter> # take the default +10m # add 10 MB t # change the type 1 # partition number b # VFAT a # toggle bootable flag 1 # partition number w # write to disk
At this point you’re back out to the shell prompt so format the USB, write the bootblocks then mount up the ISO and USB.

mkfs.vfat -n FPBX /dev/sdg1 syslinux -s /dev/sdg1 mkdir /tmp/img mkdir /tmp/usb mount -ro loop FreePBX...iso /tmp/img mount /dev/sdg1 /tmp/usb
Now let’s do some damage, er copy over the config.

cp -rpv /tmp/img/* /tmp/usb/ cd /tmp/usb mv isolinux.cfg syslinux.cfg vi syslinux.cfg # use your favorite editor and add this to the end of the append line: nousbstorage
If you needed to make any changes the booting, now is an excellent time.

Well, unmount the USB, it’s ready.

cd / sync sync sync umount /tmp/usb (Can you ever oversync?)

Now you’re good to go.