We are pleased to announce the release of FreePBX Distro

This is the first official stable release of the distro. It can be downloaded from the download page.

Anyone on the previous release can upgrade to by following the forum thread here. http://www.freepbx.org/forum/freepbx-distro/distro-discussion-help/release-versions

This release still uses Asterisk with some patches due to bugs in 1.8.4 that we see as show stoppers.


I downloaded the ISO, burnt the CD and loaded 1.8.3-1 onto my old Gateway laptop.

When I try to add a Sip extension I get a blank screen whereas with other extension types (IAX2 etc) I get the normal config screen.

I don’t know if this is a bug or if its my antiquated hardware. Before starting from scratch again could I have your comment?


Stonet- adding SIP extensions is working for me on an existing freePBX distro install that was just updated to (low power VIA 1.5Ghz based machine).

I just did another install and it lets me add SIP Extensions just fine. Can you see what the apache logs show when trying to create a extension and do you have any non freepbx modules installed.

OK so I was able to reproduce it.

[Tue May 24 17:53:19 2011] [error] [client] PHP Fatal error: Cannot use object of type DB_Error as array in /var/www/html/admin/modules/endpointman/includes/abstraction/freepbx.inc on line 0, referer:

The error is related to end point manager. I am reaching out to Andrew the maintainer of the End Point Manager. If you disable the end point manager the issue goes away

I am seeing exactly the same error in the Apache error log:

[Tue May 24 19:47:34 2011] [error] [client] PHP Fatal error: Cannot use object of type DB_Error as array in /var/www/html/admin/modules/endpointman/includes/abstraction/freepbx.inc on line 0, referer: http://testsystem.dyndns.biz/admin/config.php?type=setup&display=extensions

I disabled the Endpoint Manager Module and the issue has gone away.

I upgraded my other box with the shell script and it did not exhibit the error.

The box that you disabled the end point manager on go re-enable it and see if you have the same problem. I think it is a issue with new install of the module on a new system

I confirmed this on a fresh install of FreePBX Distro on a VMWare 3.0 Player Machine. If you remove and then reinstall the Endpoint Manager using Module Admin, the problem goes away.

To resolve this problem, uninstall and then reinstall the Endpoint Manager:

Uninstall the EPM:

Click on Module Admin. Select Endpoint Manager. Select Uninstall. In the upper right hand corner of the page, select “Process.” Click Confirm. A white box will appear on the screen. Normally, you’d see text showing the uninstall and get a button to return. Instead, you’ll get a blank white screen. Press the “BACKSPACE” KEY.

Reinstall the EPM:

Click on Module Admin. Select PBX Endpoint Manager. Click Install. In the upper right hand corner of the page, select “Process.” Click Confirm. Click Return. Click Apply Configuration Changes. Click Reload.

Now you should be able to add SIP Extensions without the blank screen problem.


I noticed that when you go to uninstall the EPM, there’s also a bug. Instead of getting text showing the uninstall getting the option to “return,” you just get a blank white screen… You can get out by hitting the backspace key, and it appears that the uninstall works…

So is this an issue or not? Seems to be a problem with install Endpoint Manager before packaging the ISO. Perhaps we should just not do this.

I re-enabled the End Point Manager and the problem was still there. I then uninstalled it and the process did not complete, hung with an orange square which I got rid of by reloading Module Admin and then found the Manager had been uninstalled. I then tried to re-install it and found that all modules had been set to disable. Got rid of that by re-loading Module Admin and then was able to re-install Endpoint Manager. Sip trunks now working correctly.

It seems to me that something has crept into the ISO that is causing this on brand new installs. I guess its something pretty small but enough to cause this problem. The good news is that there is a workaround until it gets fixed.

Congratulations Tony on a great Distro, it is really very complete and easy to install and needs hardly any tweeking after the install, everything, including Fail2ban is right there to be set up in FreePbx. I think you can be up and running with a working system without going near the root login, that’s got to be a first!

Ok we are building a new freepbx rpm today and will not be including the EPM with it. If you want EPM you will need to install it from module admin as it does not like be installed through the freepbx install_amp that we use to install all of the other modules with no issues

Ok so the distro does not install the end point manager on install anymore. You can install the end point manager from FreePBX Module Admin if you want to use it after install and it will work fine.


No they do but you need to install them in order depending on what version you were at before applying the upgrades.

Do the shell scripts not check and update asterisk to your current I have taken an existing install up to and remain at

Thanks Tony, I have updated in order. Is there a best practice/freePBX approved method of updating to freePBX’s current patched asterisk version.

just do a yum update. We lock our repos to make sure nothing bad can be installed.

Tried that…

‘yum list updates’ only showed 2.9.0-7.noarch.rpm, which I did attempt (failed).

‘yum update’ offers no packages marked for update. ‘yum list updates’ is showing asterisk18.i386 installed.