Distribution Install - No Driver Found

I’m trying to install the latest FreePBX distribution onto a new Lenovo M700. After starting the install and detecting hardware, I get a “No Driver Found” error. I am presented with a list of drivers and an opportunity to use a driver disk.

I can only guess this is related to the Realtek 8168DP ethernet chip. I have tried selecting the Realtek 8169 driver, but as soon as I do it just goes back to “No Driver Found”. I have downloaded the latest Linux driver from Realtek, but it needs to be compiled and I have no machine to do that on.

How can I get past this error so I can download and install the driver, or how can I “load driver from disk”? Does it need to be an image? And where would I even find the driver disk image? Realtek doesn’t have this. I tried installing a temporary wifi dongle, but still stuck at the same screen.


That means there is no driver for your HDD. I would suggest trying SNG7, that has a broader selection of modern drivers.

Thanks. I am trying SNG7 and that seems to be going much smoother, but two questions:

  1. How do I choose which drive it gets installed to?

  2. The install appears normal, but on reboot, I just get a blinking cursor. Any thoughts?

I am trying SNG7 since it appears it will support my hardware. Two questions have come up:

  1. The install seems fairly automated and I don’t have time to select which drive to install to. How do I select the destination drive?

  2. Install seems normal and am prompted for a reboot. After reboot I get nothing but a blinking cursor. Any thoughts here? I have tried installing a couple times.

Pick ‘Advanced’ install.

looks your system can not detect your hard disk.

Thanks, that seemed to do the trick. One odd thing to report is that my ethernet was not working (not even a link light) after the install. My eth0 config file was there, but empty. Once I populated it, all seems well.

That’s a feature of RHEL 7. The network is NOT configured on install unless you explicitly do so.