FreePBX | Register | Issues | Wiki | Portal | Support

Distinctive Ring help Yealink t46g


(Aaron Woldman) #1

I am working with freepbx 10.13.66-20 and yealink t46g phones.
I am trying to get distinctive ringing working with these phones and have not been successful.
Default ring is set to long single ring
In the phone I have enabled distinctive ring
I have a DID set up for testing and have routed it both direct to an extension and a ring group.
In both the route and the ring group I have set the ring type to #2 which in the phone is a staggered tone.

The phone is not acknowledging the custom context and only rings the default ring tone.

I have also tried changing
Settings > Advanced Settings > Internal Alert Info
to change the internal ring with no luck.


(Aaron Woldman) #2

I figured it out: Here is what I did to make the Yealink phones work with Sangoma ring settings in Freepbx

Using endpoint manager (Paid for commercial module)
Edit the basefile for the Yealink phone and add the following

account.1.alert_info_url_enable = 1
distinctive_ring_tones.alert_info.1.ringer = 1
distinctive_ring_tones.alert_info.2.ringer = 2
distinctive_ring_tones.alert_info.1.text = ring1
distinctive_ring_tones.alert_info.2.text = ring2
phone_setting.ring_type = 2

( You can set as many ringer types as you want, I only needed 2 for my needs)

Pet peave setting:
account.1.missed_calllog = 0

Who cares how many missed calls taking up your screen.


(Mike Waldron) #3

Thank you for providing this; immensely helpful!