FreePBX | Register | Issues | Wiki | Portal | Support

Distinctive Ring/ Alert Info not using custom ringtone for ring groups


#1

So I got a ring group with four S505s. I have tried setting up the Alert Into for both on the Incoming Route, and the Ring Group, but the custom ringtone is not being used. I have also tried setting only the incoming route, and the ring group to have Alert Info only, and still nothing.

To test to make sure the custom ringtone is properly functioning, I set the incoming route to go to one telephone only, and I get the custom ring tone on that telephone.

This is on:

PBX Firmware: 12.7.5-1807-1.sng7
PBX Service Pack: 1.0.0.0
And FreePBX FreePBX 14.0.5.25 using Asterisk 13.19.1

Did I miss a setting on this?


(Itzik) #2

What version core?


#3

Did you mean this?

Linux freepbx.sangoma.local 3.10.0-862.2.3.el7.x86_64 #1 SMP Wed May 9 18:05:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


(Itzik) #4
fwconsole ma list | grep core

#5

It shows 14.0.18.45


(Itzik) #6

OK yes. The way alert info works was changed. see here: No Alert Info passing through after 14 Upgrades

Try to upgrade to .46 if it still doesn’t work you’ll need to open a ticket with Sangoma.
(I didn’t had a chance to open a ticket yet myself)


#7

How do I get it upgraded? The “Updates” module is showing nothing available, and same for yum, as well as the module admin.


(Itzik) #8
fwconsole ma downloadinstall core --tag=14.0.18.46

#9

Thanks a lot for the help so far. The telephones are unplugged at the moment, so I have to go the office location to power them up as. Once I got that done, I will test and respond here again.

Edit:

oh wait. I think I am seeing Alert info:

dialparties.agi: Starting New Dialparties.agi
dialparties.agi: Caller ID name is ‘XXXXXXX’ number is ‘XXXXXXX’
dialparties.agi: CW Ignore is:
dialparties.agi: CF Ignore is:
dialparties.agi: CW IN_USE/BUSY is: 1
> dialparties.agi: Setting Alert-Info: ring6
– AGI Script Executing Application: (SIPAddHeader) Options: (Alert-Info:ring6)
> dialparties.agi: Setting sipheader Alert-Info: ring6
dialparties.agi: Methodology of ring is ‘ringall’
– dialparties.agi: Added extension 103 to extension map
– dialparties.agi: Added extension 107 to extension map
– dialparties.agi: Added extension 108 to extension map
– dialparties.agi: Added extension 109 to extension map
– dialparties.agi: Added extension 110 to extension map
– dialparties.agi: Added extension 111 to extension map

Does that look correct?


#10

Update:

With updated core version, the Alert Info is being sent again, and getting the custom ring tone.

Thanks a lot for your help!

Addition Update:

It seems the Alert Info has to be set in the Ring Group even though it is set in the Inbound Router, otherwise there is no alert Info being used.

This means a separate ring group for every different ring tone.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.