Displayed phone number when calling with TAPI


I have a problem with the selection of the correct outbound CallerID respectively the indication of the correct trunk number when calling with the TAPI.

The TAPI has an option which rewrites the CallerID (i.e. the origin) to match the CalledID (i.e. the destination).
This has the advantage that the call history of the phone does not show ‘TAPI-99’ (which initiated the call) but the external destination number (e.g.: 999-666777888).
This can then be used for redialing on the phone.

Now the problem:
If you enable this option, then the FreePBX can apparently no longer determine from which extension the call comes and takes as CallerID the parent number of the trunk (eg: 1234-5678-0).
If the option is off, everything works as desired and the correct CallerID of the extension (e.g.: 99) is signaled (e.g.: 1234-5678-99).

So is it somehow possible to activate this option and at the same time transmit the correct CallerID of the extension?
According to the developer of the TAPI this is not a problem with the TAPI itself but with the FreePBX (we use the Asterisk TAPI from xtelsio).

I made two more screenshots of a test call with the TAPI.
On the first picture the option is deactivated and the transmitted phone number is correct (extension).
On the second picture the option is activated and the transmitted phone number is wrong (trunk number)

Thank you very much for your support.
Many greetings.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.