Disabling stir_shaken

My setups are usually latest Debian with a stable version of Asterisk and Freepbx. i understand that the providers (voip providers ) are to handle the stir shaken and that there is no support to my askersisk setups from what the Providers tell me. it seems to be causing issues so i would like to disable this.

Lately thats been asterisk 18 freepbx 16

I get alot of

[2023-01-04 11:53:33] ERROR[273324]: res_stir_shaken.c:1196 ast_stir_shaken_sign: Failed to retrieve certificate for caller ID ‘xxxxx’
[2023-01-04 11:53:33] ERROR[273324]: res_pjsip_stir_shaken.c:411 add_identity_header: Failed to sign STIR/SHAKEN payload
[2023-01-04 11:53:33] ERROR[273324]: res_stir_shaken.c:1196 ast_stir_shaken_sign: Failed to retrieve certificate for caller ID ‘xxxxx’
[2023-01-04 11:53:33] ERROR[273324]: res_pjsip_stir_shaken.c:411 add_identity_header: Failed to sign STIR/SHAKEN payload

i can see these modules from the /usr/lib/asterisk/modules

res_pjsip_stir_shaken.so res_stir_shaken.so

And can not from a may this year posting that the module is not ready.

https://community.freepbx.org/t/stir-shaken-module-in-freepbx16/83270/6

can I just delete the modules ?? I after a while say a day or 2 have to fwconsole stop/chown/start because the calls stop making it to the extensions.

i have tried to disable the module by editing the (freepbx pjsip.endpoint_custom.conf in /etc/asterisk/ ) with stir_shaken=no i think I need to enter it for each endpoint but Freepbx will over write that. i am unsure how to proper disable it. https://www.asterisk.org/stir-shaken-in-asterisk/

Maybe a option could be added for each extension in freepbx for future use

Asterisk 18.11.2
FreePBX 16.0.21.3

Yes, you can delete them, or upgrade to a newer version of Asterisk 18 where it is disabled by default.

1 Like

I deleted them that did the job no more of those res_stir_shaken errors nice …