Disabling In-Call Transfer

I am attempting to disable in-call transfers using the # key on the phone. A service that calls into the house is asking for me to press # to continue the call, but in doing so, my PBX decides that I want to do a transfer.

I’ve gone into the Feature Code Admin and then disabled and changed the In-Call Asterisk Attended Transfer and In-Call Asterisk Blind Transfer to something other than #, but I’m still being prompted to select an extension to transfer to.

I go into the Print Extensions under the Tools tab, and I don’t see any In-Call Code Admin being shown.

I’m looking for a sledge hammer “fix” here. I’ll go edit the .conf files.

This PBX is used for home only. I’m the admin, the dude that installed it, god-mode admin here.

I note the two “Similar” topics regarding the proposal to disable in-call transfer features. Wish that’d get done.

Don’t include t or T in the trunk dial string options. No .conf editing needed.

https://wiki.asterisk.org/wiki/display/AST/Asterisk+13+Application_Dial

Since this is for incoming calls, don’t include t or T in the Asterisk Dial Options for the extension.
I believe that the trunk options only affect outgoing calls.

1 Like

Where am I exactly looking for this?

The closest thing I see to a dial string is in the Trunks under Dialed Number Manipulation Rules, and there is no “T”. I have two prefixes, both for NA style phone numbers.

I don’t see anything in my settings on the trunk page that’d describe anything else that looks like a dial string.

For outbound calls, it’s Asterisk Trunk Dial Options in the General settings for the trunk.
For inbound calls, it’s Asterisk Dial Options on the Advanced tab for the extension.

Thanks. I found it in the general settings, but not seeing any advanced tab when looking at the extensions. I’ll fly with this for now, and when I get some sleep (because my phone won’t stop ringing because of on-call) I’ll try and make more sense out of the inbound.