Disabling default freepbx account


I just installed AsteriskNow 1.7.1 and there is a default user of freepbx with a password of fpbx which is not listed under the administrators section. I cannot find this user in the database nor can I seem to disable it. Does anyone know how to disable this account or change it’s password?


Not sure what they are doing for authentication in that distro.

You may get a quicker answer in their forums. This is not really a FreePBX issue.

If authentication is set to database you can see all the users from the administrators module.

If they are using httpd for local authentication you will have to check the httpd configuration.

Well that’s the weird part - the administrators section by default shows “admin” and it has a password of “admin” and that user shows in the db, but the freepbx user does not show up.

Is there a file I can check to see what the authentication is set to?


What version of FreePBX? In 2.8 and lower it’s in amportal.conf. It 2.9 it’s in the advanced settings module.

Also check the /etc/httpd/httpd.conf for authentication (that path may not be exactly right).

Okay - in amportal.conf authtype=database. I did notice that the db username / pw is also freepbx/fpbx but that is different than the web authentication isn’t it?


Edit: FreePBX version is 2.8 (I just upgraded it from 2.7 using the upgrade module)

No that is a back door in case you lock yourself out. You can login with the DB credentials. That is why in our distro we use random passwords generated at install.

I don’t know if it is in 2.8 or 2.9 but there is a variable to disable DB password login in amportal.conf.

I first started with AsteriskNow and remember this being a bit tricky.
They also changed the way this was done at some time.

These two links might set you on the right path though.