Disabling authentication for register

Hi all,
I know that’s a really bad practice, but I need to configure my Asterisk installation (in an AsteriskNOW distro) to avoid authentication during REGISTERs. I tried writing the following sip_custom_post.conf the following way (for two extensions, 1000 and 1001):



, but it keeps asking for authentication. How to solve that?

Thanks & best regards

I reply my myself.
In order to do so, the password for the user should be left empty. This should be done by manually editing the config files, since FreePBX won’t allow to enter an empty password from the GUI.

If you leave out the secret for an extension you will get a warning that it is bad practice to have a blank secret, if you click OK it will save the extension without a secret, if you click Cancel you are back at editing the extension.

Do not edit the config files as they are overwritten once you click on the Apply Changes bar.

Any SIP peer/user section is ignored by chan_sip parser unless it contains type= statement.

Had you watched the log file you would notice complaints like:

chan_sip.c: Section '1000' lacks type

so they should really look like


All extensions in FreePBX has a default setting for type: type=friend

mikecarlsson is correct, do not edit the config files. No “password” screen exists in FreePBX. SIP extensions has a “secret” field that can be left blank.

I would always use an access list for security (the permit/deny) fields when no using a secret for digest authentication.

All extensions in FreePBX has a default setting for type: type=friend

Right, so chan_sip creates both user and peer definition for all extensions.

In order to uniquely identify the SIP section it is necessary not only to provide the name but also the type.
That’s why type= is necessary when extending the section using the (+) construct.

Thank you Michael, I didn’t notice it was just a warning. By the way, I used the sip_custom_post.conf file in order to not interfere with FreePBX.