Disable media from terminating on Freepbx

Having a warm timedisabling media between caller/callee from terminating through Freepbx. A little background: Currently running Freepbx(raspbx) on rpi3 at home. I have search many post for many hours but just can get the media between registered phones directly between each other and not passing through asterisk. All the below settings were made and still no luck. Please advise what might be missing. Thanks.

From Freepbx GUI

  1. Advanced setting - sip nat=no, sip canreinvite=yes
  2. Asterisk sip setting>> chan sip settings - nat=no
  3. Extensions >>advance - nat mode=no, canreinvite=yes

Asterisk is a B2BUA, if your server is behind a router (NAT) , you are probably wasting your time.

An oldie but goldie


So to get Asterisk to release media between endpoints I would have to configure public IP address directly on server? If the caller/callee are on the same LAN as the asterisk why wouldnt releasing the media be a simple feature - just not adding up.


yet that is pretty well the truth, mis matched codecs, psssing through an rg or ivr , look into a true proxy instead of a b2bua, but seriously, how many concurrent calls do you expect a p3i to handle? If you don’t need PBX functions (you can’t use them with direct nedia, then rasperry can do hundreds of proxies a second with kamailio.

Wasn’t too worried about system resource. I was more concerned with minimizing rtp delay. I have multiple family members in remote sites (International) connecting to my home PBX system as well. At any time I can have family member calling another family member from separate remote sites. (Mobile clients also involved but that another story) Anyways I actually got it working with some additional help from another post. In addtion to the configuration I posed at the top, I also added below configs.

Add below entries to Other SIP Settings
–> ‘directrtpsetup=yes’ and
–> ‘keepalive=yes’

These entries do not show on in the GUI so need to be added manually as “Other SIP Settings” at the bottom of chan SIP settings. I know this setting is said to be “experimental” in the docs but its doing its job so far.

Thanks for the quick response and assistance.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.