Disable fail2ban & use white list

We like to use a white list with our PBX’s and drop all other traffic. There are generally only 5-6 IPs/Subnets the server needs to talk with.

We have told fail2ban not to start via the OS but something starts it after reboot. When f2b starts it overwrites all of our iptables entries.

In the intrusion detection part of system admin I don’t see a place to disable f2b.

Is uninstalling it the only way to get it not to run?

Thanks for the help!