Directory not dieing after hangup

Apparently, After entering the directory script, if you where to hangup the script would still continue to run in the background. Is this a bug?

this is printed in the log files:

[Apr  8 13:57:47] WARNING[16552] file.c: Failed to write frame
[Apr  8 13:57:47] WARNING[16552] file.c: Failed to write frame
[Apr  8 13:57:47] VERBOSE[16552] logger.c:     -- <Local/#@from-internal-7f1a,2> Playing 'dir-intro-fnln' (language 'he')
[Apr  8 13:57:47] VERBOSE[16552] logger.c:     -- Playing 'dir-nomatch' (escape_digits=) (sample_offset 0)

You have provided way to little information to know.

What is the trunk type that is making the call? versions of asterisk, FreePBX, OS, etc?

In my setup I’ve never seen that.

asterisk = 1.4 freepbx 2.4, centos 5.1
This is how im calling it:

exten => badscore,n(end),Dial(Local/#@from-internal/n)

Here is a dump of what happens with you call ours… via the IVR menu from a internal phone. It see’s it just fine. I’ve tried it during the silance and while the audio is playing and both work as planned

-- Goto (app-directory,#,1)
-- Executing Answer("SIP/274-b7a215f0", "") in new stack
-- Executing Wait("SIP/274-b7a215f0", "1") in new stack
-- Executing AGI("SIP/274-b7a215f0", "directory|default|from-did-direct|beo") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/directory

directory|default|from-did-direct|beo: parsing /etc/asterisk/voicemail.conf
– Playing ‘dir-intro-fnln-oper’ (language ‘en’)
– Playing ‘dir-intro-fnln-oper’ (language ‘en’)
== Spawn extension (app-directory, #, 3) exited non-zero on ‘SIP/274-b7a215f0’

I’ve also checked the full logs and it does hang up.

Is this using a zap device (phone/incoming trunk)? might be that it is not detecting the hangup properly?

fskrotzki , i’m sure that your script is working properly. That doesnt solve my problem though. Using SIP only the script doenst hangup when I hangup the phone

I was doing it from my sip phone directly to our IVR which has the # directory enabled on our main IVR (dialed 7777 to ger there). (using * 1.2).

The only reason I was asking about zap is that sometimes not configuring the country correctly will cause the card to not detect a hangup.

I’ll take a look on my test box with * 1.4 and see if I can duplicate the issue tomarrow and let you know.