Directory Lookup Service not working


I have recently setup FreePBX and running into few issues with respect to directory lookup services using first three letters of either last name of first name. When i call into my PBX, i have setup my IVR to provide me directory assistance when i press #. After pressing #, i am asked to enter first 3 letters of either first name or last name but as soon as i enter the first two letters of the name, i get a message “no directory entry match your search”.

Any help in this regards will be greatly appreciated.

Thanks & Regards

I changed the settings in the General Setttings to find users by last name and restarted the server, it seems to be working.

The entries in the voicemail.conf are exactly the same as you mentioned.

Thanks for your help.

The Directory (not the same as Phonebook Directory) uses the voicemail.conf file for names. Do you have any extensions defined with voicemail? If not then it will not have any names.


I have all the extensions configured with voicemail and still get the same error.


ok, open the voicemail.con file and let’s review it.

At the top will be the [general] context and under that context there really should be just two lines


After that normally comes the [default] context and that is where the extensions are placed. Each extension has the format of:
ext# = passwd,Human name,e-mail_address,pager_address,options
There should not be any [] lines in the file.

The only other context’s that might exist are [zonemessages] which is ok (if you have remote offices, extension in different timezones you’ll want this) and if you created a non-standard voicemail context (not to be confused with a dialplan context) then that will also be created, but 98% of the world takes the default unless they want to restrict voicemail for groups.

You can see a example at search down the list for voicemail.conf.

If you are not sure what you are looking at and don’t mind posting the file I will look at it here.