Directory Help

Hey everyone, having some troubles here and hoping someone knows the fix.

Directory v.

When I dial 411 and enter 3 letters, the directory will only spell names. Even when I change it to voicemail recording or text-to-speech, it continues to just spell names.

I have tried uninstalling/reinstalling, upgrading, even setting permissions to greet.wav to 777. Asterisk is set to the file owner. Not sure what could possibly be wrong here.

I appreciate any help at all.

Kevin Cuffel

Did the users record their names in the voice mail?

Yes. Each extension has a greet.wav recorded. I tested with multiple extensions. It is still just spelling the names.

Thanks for the reply!

I listened to the greet.wav just to be sure it was really there, and it was. The recordings are valid.

You don’t really have to do anything it just works.

Grab some log output when you use the directory and post it.

Your issue is 411 does not go to the directory module. 411 dials the Asterisk Phonebook. Setup a misc Destination that goes to your directory and than dial that.

You were correct. Although now the “No directory entries match your search” just loops over and over. No other files are played. Only this one, as soon as the call is connected.

I have tried uninstalling/reinstalling and that did not help. Do any of you have any ideas.

Thank you all so much for your replies thus far.

Kevin Cuffel

Sorry if this is too simplistic of a question, but did you put any users into your directory?

Yes, I have users in my directory. :slight_smile:

Oh, and the issue now is that nothing is being heard. No server prompts are there. Not for the directory, voicemail, anything…

[2012-05-14 07:02:53] WARNING[17079] file.c: File pbdirectory-welcome-to-phonebook does not exist in any format
[2012-05-14 07:02:53] WARNING[17079] file.c: File pbdirectory-first-three-letters-entry does not exist in any format
[2012-05-14 07:02:53] WARNING[17079] file.c: Unable to open pbdirectory-first-three-letters-entry (format 0x100 (g729)): No such file or directory

File permissions are 777 for testing and asterisk:asterisk

It’s saying the files aren’t there… even though they are…?

Do you have g.729 installed on your system? If you don’t have the g.729 CODEC (requires a license per channel from Digium) you would get this error.