Direct to VM Not Working

voicemail
Tags: #<Tag:0x00007fafc0f720e8>

(Shackbill) #1

We configured EXP100 and S505 keys for Direct transfer to voicemail using DTMF ##*XX and it seemed to be working at some point but now we gt nothing at all. No tone no transfer? Does anyone have an idea how we can push a call directly into VM without ringing an extension?

thanks


(Lorne Gaetz) #2

BLF buttons blind transfer by default, so you should be able to set a BLF (or speeddial) to *XX where xx is the extension number. Assuming you’ve not changed the direct dial to vm prefix from the default of *


(Shackbill) #3

Ok. im almost certain we tried that before but alas it does seem to work that way now? But, i tried to set the LONG PRESS prefix as * and the BLF key as the extension number and the long press doesnt activate the direct to VM. i suppose im back to this Previous discussion but now with BLF? Thanks for your input.


(Lorne Gaetz) #4

Can you pick up the phone and dial direct to VM by dialing *XX? If not, there is something else going on, a full call trace will tell you what:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII

also see this post Transfer to VM Rest-API Call cannot be completed as dialed


(Shackbill) #5

Yes we can direct dial. And the short touch *XX on EXP100 also works but not the LONG touch


(Shackbill) #6

just figured out that this feature (*xx) works if i make a call fro an internal extension or just press the button on the EXP100 but if i try to transfer a call from outside (inbound route/Queue) the phone just goes on hold and never transfers. In other words, a call comes in on the Queue…we preess the tRANSFER button then the EXP100 button that corresponds to the destinatin vm ie… *30 and nothing happens. Any ideas what would cause this?

thanks.


#7

Try posting a log of a failed transfer and we might be able to see what’s happening.


(Shackbill) #8

ok first let me make sure i am clear about my issue.

If a call comes in from an external source, i press the TRANSFER button on the S505. Then i press a BLF Key on EXP100 that is configured with *xx for Direct Transfer to VM. I get NO TONE at all when i press this key and nothing happens - the caller remains on hold.

If i make an Internal call to another extension, then press transfer button and then BLF key on EXP100, the call is immediately transferred to VM.

Ive attached 2 logs. the first is the external inbound call that didnt trasnfer, the 2nd is the internal call that was success.

Thanks for assistance.

EdIT: These logs were too big to paste here and i couldnt attach txt file so heres some public links.

External Call Fail Transfer

Internal Call Success Transfer


(Lorne Gaetz) #9

Default behavior of BLF buttons (and speeddial) is to blind transfer live call. You don’t need to press the transfer button, just press the BLF to transfer a call.


(Shackbill) #10

That does not work. Nothing happens when i press the BLF key on EXP100. Note: If i change the account # that the destination is associated with, the transfer into VM then works. But then it doesnt work for internal transfers.

More info: We have two companies configured for one phone so there are 2 queues each queue has a different extension assoicated with it (and different acct #) so that all phones can ring for both Queues.

So it seems that external calls are ringing as a different acct # (than the internal accts) so the BLF transfer key doesnt see a pending call? Does that make sense? Im not sure how we can configure this so the internal and external calls use the same acct.I realize this thread is sounding very confusing but i dont know enough yet to write it any clearer…


(Shackbill) #11

ok we have most of this working now. We consolidated the queues to use the same acct. sorry for all this confusion. this is a bit of a curve for me…


#12

So you have 2 different extensions? If so, each extension has its own buttons associated to each of them, that is why you need to specify the account=extension