Digium Phones Module on newer versions of FreePBX wont Reload

I had the DPMA module working on FreePBX Distro 6.12.65-29, I upgraded since that trunk is going to be eol for support. However in every version past that I cant reload because of the following errors. I tried upgrading to DPMA 2.2 and everything else I could think off. Is there something I am missing. I do have DIgium phones so I cant just disable it. I am now on FreePBX Distro 10.13.66-5. I tried upgrading to asterisk 13 and upgrading the module from binary.

exit: 1
Whoops\Exception\ErrorException: Invalid argument supplied for foreach() in file /var/www/html/admin/modules/digium_phones/conf/res_digium_phone_devices.php on line 193
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/modules/digium_phones/conf/res_digium_phone_devices.php:193
  2. Whoops\Run->handleError() /var/www/html/admin/modules/digium_phones/conf/res_digium_phone_devices.php:193
  3. res_digium_phone_devices() /var/www/html/admin/modules/digium_phones/functions.inc.php:435
  4. digium_phones_conf->generateConf() /var/www/html/admin/libraries/BMO/FileHooks.class.php:65
  5. FreePBX\FileHooks->processOldHooks() /var/www/html/admin/libraries/BMO/FileHooks.class.php:24
  6. FreePBX\FileHooks->processFileHooks() /var/lib/asterisk/bin/retrieve_conf:823

So I tried all the modules for asterisk 13 from the digium site and updating all the modules and even running a bunch of upgrades from the cli. Does anyone have DPMA working at all with the newer version? Or should I just go back to the last version that was working which was 6-12-29 but had other issues?