Digium Phones edit page doesn't save changes

When I go to Connectivity > Digium Phones and click Edit on my phone, and then change any settings and click Save, none of my changes are reflected on the reloaded page. I’ve tried several different fields, including Phone PIN, Phone MAC Address, Timezone, Name Format, and on an on, and none of them change when I click Save.

Also, no firmwares appear in the drop-down menu for Select Firmware. I have gone to the firmware page and clicked Check for Updates, and have one firmware listed there (firmware_1_3_3_0_package). Is that supposed to appear in the firmware drop-down on the phone’s Edit page?

I’m on FreePBX distro with FreePBX and Asterisk 11.4.0. The Module Administration page shows Digium Addons and Digium Phones Config

Any help would be greatly appreciated.


We are aware of the issue and hoping to have it solved this week.

We’re looking forward to the fix :slight_smile:

Sorry if this is a “dumb newbie” question. I’ve been using AsteriskNOW for a while and just tried the latest version of FreePBX distro. All of my desk phones are Digium D40’s so this module is kinda an important one for me.

is there somewhere you’ll announce the fix once you’ve completed it? thanks!

You can track items like this at issues.freepbx.org… unfortunately I see lots of forum post about this issue, but not a single ticket.

Forum post don’t necessarily get action… would be great if someone with this issue would open a ticket.

Same issue! What we have to do?

two posts up in this thread…

"We are aware of the issue and

We are aware of the issue and hoping to have it solved this week.

Tony Lewis
Schmooze Com, Inc.
FreePBX Developer"

In my opinion a ticket is always needed, probing for people having similar issues in a forum post is fine, but once an issue is confirmed a ticket should be added at issues.freepbx.org, it provides a place for others to see the status of the issue, it also provides documentation in the future if that issue is re-introduced.

On this particular issue, there are at least 5 different threads started across multiple forums, so the development team is aware, this is a community based project get involved, look at existing tickets at issues.freepbx.org, vote on features you would like to see implemented, or bugs you that you would like to see escalated. The community helps determine how the development resources are used.

Preston, I understand your point and don’t disagree, I would have been happy to enter a ticket however from Tony’s post I got the impression it was already being worked and therefore a ticket either already existed or was not necessary.

I work for a company that develops software and while a bugtracking system is great, it can also become a wild mess if tickets are created when not needed.

In any event. If you would like me to open a ticket on this issue let me know and give me a link to do so. (Kinda new here, still finding my way around).


We will let you know on this thread when the fix it out.



The ticket for this issue has been closed, and the update pushed in module admin version of the Digium Phone Module, http://issues.freepbx.org/browse/FREEPBX-6747

Please report any additional issues or bugs at issues.freepbx.org

seems to work fine. I’ll create a ticket if I find anything else. THANK YOU!

The Edit page is now working. Thank you.

However, at the top of the page, I’m seeing this message:

The firmware package location /var/www/html/admin/modules/digium_phones/firmware_package/firmware_1_3_3_0_package does not exist.

This is the firmware version I originally downloaded on the Firmware page, but it’s no longer in that directory, and I can’t find any reference to it in any of the .conf files. Furthur, when I go to the Firmware page and click Check for Updates, nothing happens. My clicks on that button don’t show up in /var/log/httpd/access_log either.

Jim Cain

As we asked very nicely please open bug tickets. Developers do not monitor the forums for bugs. Especially this one since Digium is working it and they get notified anytime a bug is opened for Component Digium Phone Module.


Apparently that bug tracker app doesn’t share its user database with freepbx.org and this forum, and I don’t a way to register for it online.

Actually I have found the issue. The JavaScript on the Firmware page was getting a syntax error, caused by that error message at the top of the page:

The firmware package location /var/www/html/admin/modules/digium_phones/firmware_package/firmware_1_3_3_0_package does not exist.

It’s being inserted bare into the contents of the script tag, causing the syntax error and keeping the browser from parsing the remaining JavaScript, including the function that is called by the onclick for the Check for Updates button, process_update_firmware().

My workaround was to find the firmware entry in MySql and delete it. (It wasn’t being referenced in a config file, as I mistakenly assumed previously.) Once I deleted that record and reloaded the Firmware page, there were no JavaScript errors, and clicking the Check for Updates button worked as expected.

All of the accounts are linked through a central server so your user account works over there. Just go to: http://issues.freepbx.org