Digits not working in VM when access from an avaya

freepbx
Tags: #<Tag:0x00007f70278b0a08>

(David Johnson) #1

I have a new customer connected to my FreePBX. I have several Grandstream GXW4248’s connected to my PBX from several remote properties. I have had this setup for almost 2 years without any issues but just added a customer who has an Avaya phone system to the Grandstream (analog ATA). I am having an issue where the customer can NOT get into the VM from their phones on the Avaya. After some diagnostics I can see that the VM is not getting any digits and just says wrong password to everything. If I turn off password required from same extension they can get into VM but then cant do anything. It doesn’t hear any digits including the # although I have no problem dialing the *97 to get into VM in the first place? Makes no sense. As soon as the VM picks up the dialing stops working? Any suggestions on how to fix this? I thought that maybe it was the Avaya blocking dialing after the call is established but the customer says they had Verizon voicemail on the old trunks which they had no issues accessing.

I have this setup with 3 analog lines on the GXW4248 in a hunt group connected to CO lines 1, 2 and 3 on the Avaya. If I call the main number from my phone (in my office voip phone externally) or a cell phone via the 10 digit external number I have no problems accessing the VM.

When I press the digits on the Avaya phone I do hear them. I though maybe they were too short but I tried pressing them longer as well and it didn’t make a difference.

FreePBX 14.0.13.40
Voicemail14.0.6.13 Stable and up to date


#2

In the GXW, try disabling Fast RFC2833. If no luck, try disabling DTMF Negotiation and then trying both in-audio and RFC2833 for first priority DTMF method.


(Dave Burgess) #3

Just guessing, but is the ATA eating them? Lots of these devices will “interpret” button presses in an effort to “help” you, which of course just screws us up.

If the GXW has a setting to just ignore all button presses (or what @Stewart1 said) I’d start with that. There is a way to debug DTMF on Asterisk, but if the tones aren’t even getting there, you’re stuck.


(David Johnson) #4

I only say they are not getting there because I didnt see them when I was in “asterisk -rvvvvvv”, I wasnt doing any other DTMF debugging. Is there a better way to do that?


#5

Add DTMF to your ‘console’ and ‘full’ entries in the settings -> log file settings -> log files


(David Johnson) #6

Thanks all for your help. I have resolved the issue. The problem was in the GXW. After a suggestion in this thread I went and read through the bug fix log for the GXW product line and I see that there was a bug fix in the profile->profile 1->audio. The GXW has 3 options for DTMF decoding but has a bug where all 3 options are “in-audio” even though there are 3 choices (RFC-2833, SIP Info, and In-Audio). When I changed them so that option 1 is RFC-2833, option 2 is SIP Info, and option 3 is in-audio it now works. I’m not sure why it even allows you to select the same choice for all 3? It should offer a priority list where you list the 3 choices in order of preference. But in any case it is working now without any issues.