FreePBX | Register | Issues | Wiki | Portal | Support

DIDs from trunk doesn't pass through / doesn't route correctly anymore


(Pasco) #1

Since I’ve updated/reinstalled a module of my FreePBX Distro (I can’t remember it’s name) all incoming calls from that trunk are routed to the trunk main number. Also in the CDR Reports under the row “DID” it only shows the main number from the trunk. My sip-provider still passes through the various numbers, I’ve checked this with sip set debug on. In the “To:” there is the correct DID. But under “Contact:” there is the trunk main number. And it’s routed like the main trunk number.

Until this update/reinstall of the modul everything was working great…

Thanks for any help.

Cheers,
Pasco


(Lorne Gaetz) #2

I don’t see how your provider can have changed the format of an inbound INVITE based on the PBX module versions. If the DID is in the To: header, your trunk context(s) should be set to:

from-pstn-toheader

(Pasco) #3

Great, I’ve changed the outgoing/incoming sip settings under trunks, also inserted your suggestion and now it works again - THANKS! The strange thing is I’ve nothing changed in the settings before, only reinstalled a core module and restarted the box…

I recognized that I have also problems with the DAHDI Configuration. Each time I push the button “Restart DAHDi & Asterisk” it resets the Digium-Card-settings. Maybe there are more problems with my installation. Maybe it’s time for a fresh install, as I upgraded my systems along the years several times…


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.