DID with alphanumeric characters


I have a trunk setup that I can dial out on, but I’m trying to setup an inbound route, and coming unstuck. I am trying to tell FreePBX that my DID is 012133322NDND (my phone number on this trunk is 012133322) but of course FreePBX is saying my DID has to be numerical only.

Can I somehow send all calls from this trunk to a certain flow without needing to use a DID?

Any ideas?!


If this is a chan_sip ‘register’ trunk, just put the number at the end of your register string, e.g.
012133322NDND:[email protected]/012133322

Then, incoming calls will appear (to your Inbound Routes) as being sent to 012133322.

If it’s pjsip with Registration Send, set Contact User to 012133322 which will do the same thing.

If you have multiple DIDs on the account or are using IP authentication, please post details.

1 Like

For the record a DID (Direct Inward Dial) is not a SIP thing, it is a Telephony thing. PRI, T1, POTS, etc. have DIDs as it is the number that can be dialed to reach the destination.

Use alpha characters is a SIP URI and the only way a phone will dial that is with SIP URI Dialing enabled on the phone so you can use a-z without it being coverted to a digit.

Thanks, Stewart, this did the trick! Great!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.