DID to a specifc extension

Dear friends, I’m using an external provider (Zadarma.org). I have connected this trunk to my FREEPBX server with no problems. I can make calls with no problems and i also can receive calls if i set up an Inbound trunk for any CID/ Any DID. But, if i try to create a specific inboud route, typing my DID number and pointing it to a specific extension, when i try to call i get a messagem “The number you have dialed is not in service, please check the number and try again”… I wish to know if is there any option to point a specific trunk pointed to a specific inbound route, many thanks

Check the CDR for one of the inbound calls using the Any/Any route. What do you see in the DID column? If you have a numeric value there, it must match exactly what you are using for DID on the inbound route.

Humf… Many thanks … I think that my provider is not sending the DID properly
" _-- Executing [[email protected]:4] ExecIf(“PJSIP/118723-201-0000003e”, “1?Set(_FROM_DID=s)") in new stack

It’s possible the provider uses the To: header for this, try setting the trunk context to:

from-pstn-toheader

Many thanks! It’s working well now!!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.