DID problem / BabyTel SIP trunk

Hi guys,

I have a trunk with BabyTel that has 8 channels and 5 DIDs.

Every DID has a inbound route, which leads to a specific IVR.

The problem is that whatever DID I’m dialling, it always ends up passing the main DID of the account.

For example, my trunk has 5 DIDs : A, B, C, D and E.

If I dial B, C, D or E, it will still be displayed in FreePBX as A.

So just for privacy purpose, I have replaced the phone number with this : AAAAAAAAAA to show you what I mean.

In the CLI, if I dial B, C, D or E :

Executing [[email protected]:1] NoOp("SIP/sip.babytel.ca-00000000", "Received incoming SIP connection from unknown peer to AAAAAAAAAA") in new stack
    -- Executing [[email protected]:2] Set("SIP/sip.babytel.ca-00000000", "DID= AAAAAAAAAA") in new stack
    -- Executing [[email protected]:3] Goto("SIP/sip.babytel.ca-00000000", "s,1") in new stack

So in the end, no matter what number I dial, it is always treated as A.

So my inbound routes and DIDs are not used.

I would really like to fix this quick so do you have any idea of what I could do about this?

Anyone knows a little bit about BabyTel?

The number is not the problem - the calls are arriving unrecognized from BabyTel - Here:

“Received incoming SIP connection from unknown peer to …”

From this limited snip, it looks like either a catch-all route is picking up the Anonymous call or your anonymous call handling is mangling it - from a SIP trunk provider, you should recognize when they are sending you traffic - the inbound settings on your trunk need looking at.

Greg

There is something configured incorrectly in your trunk config. Post your trunk config.

Babytel is notorious for this. They send from a different peer and tell you to do some hacky /etc/hosts file changes to fake the system.

Hi guys,

Finally I found a workaround…

I created 5 different trunks, each are exactly the same, except for the register string.

I have 5 DIDs associated with my account, therefore I need 5 different register string.

Now it works fine ! I didn’t have to do anything else.

I guess it is not “ideal” but it works for me.

The register string, for anyone running into the same problem, is as follow :

<A>@sip.babytel.ca:<B>:<C>@nat5.babytel.ca:5065/<A>

Where

A : The “virtual number” or DID you want to register
B : Your SIP account password
C : Your SIP account username (main phone number)