Dictation weirdness

ok, back in another thread I had a problem enabling dictation and I think I have some more insight into this.

I filed a bug as asked, but it was closed out because it couldn’t be reproduced - and I think I might know why.

I think most are running with “extensions” and not so much “deviceanduser”.

I noted that when I’m running “deviceanduser” I can’t seem to get dictation to enable for a user - but when I’m running “extensions”, I can do it just fine - and I have the impression a lot more are running with “extensions”.

I’m not sure where to look to correct this - or if it’s just something that I can only do with “extensions”… or if I’ve done something else wrong.

Any insight?? Also, I’d be willing to give someone in the know access to the host I’m running on - it’s not production - in fact, it’s a fresh build.

CentOS 5 (VM)
Zaptel 1.4.5
FreePBX 2.3.0RC1.1
-Core 2.3.0RC1.2
-Framework 2.3.0RC1.1

Any/all help is appreciated!

you need to be a bit more specific on what you mean. Spell out step by step what you observe when running in extensions mode vs. device/user mode and point out specifically what you mean when one works and one does not.

It should be designed to work in both modes (under the covers everything is actually devices and users) but there could still be something wrong in the code that breaks in one mode vs. the other so it does not get setup.

So, as I said, this is a completely fresh install on a fresh server - no trunks, no extensions, no users, devices, nothing…

I have all the FPBX modules installed and updated EXCEPT zork, gabcast, and customerdb.

AUTHTYPE=database and the user I’m logged in as has access to “ALL SECTIONS” with no extensions or department specified.

[list]1) Edit /etc/amportal.conf and set AMPEXTENSIONS=deviceanduser
2) amportal restart

  1. Logged into FreePBX and create new user
    [list]a) set extension/passwd, etc…
    b) set Dictation to Enabled
    c) set Format to Ogg Vorbis
    d) set email address
    e) hit submit
    f) I’m brought back to empty create form, but I now see the new user in the list and I have an orange bar.
    g) “Apply Configuration Changes” and “Continue w/ Reload”[/list:u]

  2. When I go back to look at the user I created, Dictation is disabled and the other fields are at their defaults. Repeat 3b-g yields no change.

  3. Edit /etc/amportal.conf and set AMPEXTENSIONS=extensions
    [list]a) bail out of portal, amportal restart, log back in[/list:u]

  4. Create extension as in step 3 - after “Apply Config. Changes” and “Continue w/ Reload”, extension shows dictation enabled and settings as entered.[/list:u]

Like I said, if you want to see it for yourself, let me know and I’ll give you all the access you need - there’s nothing on this server at the moment :wink:

Also, thanks so much to everyone here and ALL the developers! This stuff ROCKS!!!

I have about 15 extensions originally created in “extension” mode, but I needed to switch to “deviceanduser” mode to make it convenient for users to have both a stationary main phone as well as a mobile softphone.

After changing to “deviceanduser” mode I can no longer edit the dictation settings on users. It simply loses whatever I enter in that section if I click submit.

Happy to dig for more details if needed. Just let me know.



Hmm - seems maybe I’m not alone - also seems this is related to being in deviceanduser mode vs. extensions only…

Should I file this as a bug again?

Busy Busy over at FreePBX HQ - looks like 2.3.0 wen’t live on us all of a sudden!

I caught 16 different module updates… installed them all…

Anyway, this glitch seems to still be there…

I’ll file a bug, and see what happens…

Congrats on the release!! AWESOME AWSOME


Actually, I’ve had this problem enabling Dictation in FreePBX for some time and I just saw this thread. When I toggle Disable/Enable to “Enable” and hit “SUBMIT”, it still stays at DISABLE. However, it works great if i’m not in deviceanduser mode.

I had thought this was something i’m doing, so it is encouraging that lots of other people are tripping over this as well.


See patch in ticket - please test and report back in ticket so we can move it to 2.3:


Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx