Dial plan help

Hi could someone help me setup my dial plans as am really struggling what the problem is that am registered with callwithus and i cant ring out unless i dial e.g 441434 624584 instead off 01434 624584 and same with mobiles needs to be 44 before the number instead of just 07 is there a way to set the dial plan correctly.

i hope you understand what i mean as am confused my self LOL

Cheers lee

Try this in your outbound route, leave trunk “Dialed Number Manipulation Rules” blank:


Tried that and no luck heres the dial plan fields in webgui just to make sure i have done it right.

Yes this will strip the 0 and prepend 44
You need to delete the other two entries

still not working seems freePBX is still using the number i dial into phone an not stripping the 0

freepbx log file:

Executing [[email protected]:6] Playback(“SIP/101-00000050”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack

Plus now i cant Dial out at all

think i have fixed it i changed the Z’s to X’s so XXXXXXXX.

X = matches any digit from 0-9
Z = matches any digit from 1-9
N = matches any digit from 2-9

Since you were dialing 01434 624584 it would not match on Z.

Thanks for your help

Yes, should have been “X” sorry, memory not what it used to be.


Glad you are all set!

outbound route
console error log
= Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [[email protected]:1] ResetCDR(“SIP/9802-00000003”, “”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/9802-00000003”, “”) in new stack
– Executing [[email protected]:3] Progress(“SIP/9802-00000003”, “”) in new stack
– Executing [[email protected]:4] Wait(“SIP/9802-00000003”, “1”) in new stack
> 0x7ffc1c006f40 – Probation passed - setting RTP source address to 192. 168.10.116:5004
– Executing [[email protected]:5] Progress(“SIP/9802-00000003”, “”) in new stack
– Executing [[email protected]:6] Playback(“SIP/9802-00000003”, “sil ence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
– <SIP/9802-00000003> Playing ‘silence/1.gsm’ (language ‘en’)
– <SIP/9802-00000003> Playing ‘cannot-complete-as-dialed.gsm’ (language 'en ')
== Spawn extension (from-internal, 9656460000, 6) exited non-zero on ‘SIP/9802 -00000003’
– Executing [[email protected]:1] Hangup(“SIP/9802-00000003”, “”) in new stac k
== Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/9802-00000003