Dial outbound number not sent to trunk

Hi, I have a new FreePBX install from AsterixNow distro. I have a voiptalk.org account and a successfully registered SIP trunk.

The problem is I cannot dial out. By running SIP DEBUG from CLI I am able to see that it is treating the outbound number as an extension.

The install instructions followed are here https://www.voiptalk.org/products/asterisk-voiptalk-sip-trunk-registration-using-outbound-proxy-setup

As you can see it instructs you to set the context within the SIP trunk to “voiptalk_incoming”. However this doesn’t tell you what to set the context of any extensions to! So I have tried this context, the context “default” and “from_internal” yet when I go to make an external call it just logs that extension 100 tried to call an extension which was not found in the specified context.

I have an outbound route specified and have tried various patterns and have now just opted for a generic 9X. pattern with a 9 prefix so that should accept just about any number and strip the 9 off I think?

Unfortunately the voiptalk installation instructions are telling me to hack the files directly, but the files themselves say not to play with them as they are autogenerated.

Can anyone please interpolate this outdated instructions and tell me what context to use for my extension so as to be able to route 9X. calls to the SIP trunk?

Can you post what your dial plan looks like for the trunk(s)? It sounds like your dial plan might not be getting matched to a proper outbound route.



Your context for the extensions is: from-internal


Remove the context from your trunk (the default context is from-sip-external).

Thank you,

Daniel Friedman
Trixton LTD.