Device & User mode


I need to set up Device & User mode, i have freepbx 2.8.
I modified the amportal.conf AMPEXTENSIONS=extensions to AMPEXTENSIONS=deviceanduser and restarted amportal.conf, i read that the extensions tab in FreePBX GUI will be replaced with 2 tabs, Device and User…

Can anyone help??

I just checked this again and it’s working. It shows up on Devices. at the bottom. In FreePBX 2.9. EPM 2.9.x RC7

Options are not showing in the User nor in Device, additionally i can’t get Device and User mode to work on 2.9, i am manually editing amportal.conf, like i do on 2.8,
it works on 2.8 but not on 2.9.


see response in your other post.

Thank you :slight_smile:

looking forward to 2.9!!

I finally figured out devices & users group and its pretty neat to use.
Will it always logout the default user on that extension?

For instance, say you have extension 1000 and extension 2000 wants to login to that phone. *11 > 2000 > password > “thank you”.
2000 calls should ring but 1000 would be sent to voicemail. Do I have a misunderstanding of this?

It works in Device & User Mode but won’t show options under the Device Page in FreePBX. It will only show options in the Extensions page. This is fixed on my local build

Also. FreePBX 2.9 is awesome in regards to editing the amportal.conf file,as you’ll no longer have to do this! It’s great.

It will ‘work’ with device & user mode. But I haven’t looked at it in that mode in a LONG time. I’ll check it out tonight make fixes and get it out asap

well first i did this modification AMPEXTENSIONS=extensions to AMPEXTENSIONS=deviceanduser but nothing happened and reloaded the GUI and restarted, still i was seeing Extensions and not deviceanduser…it still worked the same as it was working…that’s my first question, second i intend to use deviceanduser mode with Endpoint Manager, but the way it is configured now, it’s getting its extension from the tftp server automatically, how can i enable deviceanduser mode with Endpoint Manager provisioning…


you probably need to get Andy to help here, I don’t know if he is assuming that FreePBX is in ‘extension’ mode wrt to what he is doing or not.

well actually a device is not an ‘extension’ as it is not even possible to dial a device.

The best way to understand it is that in extension mode, an ‘extension’ is a ‘user’ and every ‘extension’ has one ‘device’ mapped to it as a ‘fixed’ device.

In deviceanduser mode, each user is an ‘extension’ and as such, you can dial a ‘user’. Each ‘user’ may have 0 or more devices associated with them but in all cases you can call a ‘user’ even if they have no ‘device’ connected. (They may have a follow-me, VmX locater, etc.

In addition, you can make ‘adhoc’ devices which allows any ‘user’ to log into that ‘device’ even if it has a default ‘user’ that it belongs to.

btw - there is no need to do an amportal restart when switching the mode. Furthermore, you can switch back to extension mode once you have created any changes you want. If there are devices that are not fixed, you won’t have access to them but they will still be there. Basically, FreePBX is always in deviceanduser mode, switching the mode simply switches the GUI presentation and allows a few more fields to be configured that normally are not available.

You’re right so far. You won’t see extensions anymore but devicesandusers.

Device would be an extension which is tied to the phone and user is who you want to login to the phone. For instance, you could have 5 extensions but 10 users. Those ten users would be able to login to those extensions and receive the calls there.

Did you have any specific questions?

In Device and User Mode
Tried changing the line label from displayname to user_extension
The phone then shows “none” even though a user is logged in.
Tried $username and it showed the device #, not the logged in user name.
I’m stuck on this.