Detecting the busy tone

Since our U.S. telco isn’t providing the CPC voltage drop when the call disconnects, we need our system to detect the fast busy tone. Our system is the FreePBX Classic with a Sangoma B600D Analog Voice Card. We tried these settings:

Enable Busy Detect: Yes
Busy Detect Count: 3

We didn’t specify anything for busypattern since with nothing specified, it should detect any cadence pattern. It’s detecting the howler tone, but not the fast busy signal that precedes it. Could this be because it’s detecting the frequencies for only the howler signal? If so, where can we change it to look for the fast busy signal frequencies?

You need to detect specifically, from :-

dual-frequency tone of 480 Hz and 620 Hz at a cadence of 0.25 seconds on, 0.25 off

Dahdi normally does that but maybe you can be explicit about it in busytone=

When we specified to detect a cadence of 250mS on and 250mS off, it didn’t detect any tone at all, including the howler signal that it had been detecting. That would seem to indicate that it’s looking for the howler frequencies but not the fast busy frequencies.

Do you mean that chan_dahdi.conf has a “busytone” parameter for defining the frequencies? I’m unable to find it there.

try a very particular


I can’t say it will work because I don’t have that problem.

Thanks for the suggestion. I tried it and the result was the opposite of what was intended-- the line stayed busy even longer and required a physical disconnect.

Can you supply a link of how to specify frequency in the “busypattern”? I searched for this and could not find anything.