Deprecated freepbx modules stopping update to 16

I just noticed that my FreePBX appears to be outdated. I wondered why I wasn’t getting module update notices for a while.
But when I run the tool to check requirements I get a series of errors saying modules are deprecated. I don’t even see some of them in my modules list so I’m left with no idea how to remove them.
The list is

So how do I remove these so I can proceed with the update?

For each of those names, from ssh,

fwconsole ma delete nameofmodule

Then you will be able to proceed.

Thank you. That worked for most of them. When I try to delete the Digium_phone_module it says the Specified module not found. But when I run the checker prior to upgrade it still finds it and says it’s depreciated.

Found 16+ deprecated ‘Digiumaddoninstaller/Digium_phone_module’ modules | Digiumaddoninstaller/Digium_phone_module are deprecated / not supported in PBX 16+ systems.

I’ve tried deleting both the name “Digium_phone_module” as well as the longer name “Digiumaddoninstaller/Digium_phone_module” but both times it says the specified module not found.

I’m also getting an error saying there are files owned by the root user in /var/www/html I have no idea what those files are. Can I just delete them all?

1 Like

The module names you’re looking for are

# fwconsole ma listonline | grep digium
| digium_phones        |            | Not Installed (Available online: 15.0.12)    | GPLv2       |           |
| digiumaddoninstaller |            | Not Installed (Available online:   | GPLv2       |           |

so the command you want is

fwconsole ma delete digium_phones digiumaddoninstaller

Thank you Lorne. I got an error when I ran it saying it successfully deleted digium_phones but then right under that it says Specified file not found, which must have been for the digiumaddoninstaller? Either way when I run the check it no longer finds those errors.

The only error I have left is those root owned files in /var/www/html

You can correct most ownership/permissions issues with

fwconsole chown

Wow. A pile of dangling sound symlinks… whatever those are. LOL

Funny thing is that it didn’t report any changes in that /var/www/html directory yet the error is now gone. Looks like I’m ready to do the upgrade. Fingers crossed. Thanks again Lorne.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.