Depracated dialplan code after FreePBX and Asterisk upgrade

I upgraded an AsteriskNow 1.7.0 system from FreePBX 2.7 to 2.8.1 using the GUI. The upgrade had no errors. I then upgraded the Asterisk RPM packages from 1.4 to 1.6 also also with no errors. When I began to use the system I ran into the following issues:

  1. ASTVERSION never got updated in extensions_additional.conf and sip_general_additional.conf.

  2. The dial plan is using deprecated applications in the code. In the dial plan I’m seeing message like following:
    – Executing [[email protected]:2] ExecIf(“DAHDI/1-1”, “1 ,Set,CALLERID(name)=”) in new stack
    [Jul 29 09:20:23] WARNING[25535]: app_exec.c:222 execif_exec: Deprecated syntax found. Please upgrade to using ExecIf(?Set(CALLERID(name)=))

The NET result is that the system didn’t work properly until I updated the ASTVERSION variable to from 1.4.33. It works now but there is deprecated code that won’t work once I upgrade to Asterisk 1.8. Did I fail to do something during my upgrade process? Is there an automated method to update the dial plan files that I missed? Do I manually need to remove the deprecated code?