Deliberate Error - FreePBX Distro 7 - Cant Send-Logs or Install

I’m not sure if I should be posting this at issues.freepbx, but I am trying to do an “advanced install” of FreePBX Distro 7. I was able to install via “Custom” and “Automatic”, but I don’t want LVM so I’m trying to use Advanced. Based on the Wiki, I tried removing the second disk /sdb, but I still get the error!

I then tried to send-logs, but my machine has no IP address. I created the ifcfg-eth file, but ifdown and ifup don’t work, nor does service network restart. I can’t figure out how to even submit logs, let alone resolve my problem. The machine currently has 1 Array of SSD’s in it via a Hardware Raid Controller (Adaptec 6405e). This seems a little obsurd, as I want to choose the disk layout, but this failure is supposedly because it “cant figure out which disk to use”. (Let me choose for you!)

All I really want is no LVM, but thats sort of another topic… (headbang)

Note: I also tried UEFI and MBR, same thing :frowning:

If your machine has no IP address, then that’s another problem. It’s possible that the machine you’re using has a network card that’s not usable.

(Or, the network port you’re plugged into isn’t eth0 on the system. If you have multiple network ports, try a different one)

I tried 2 of the 3 NIC’s. Seems fairly basic for an installer to configure a secondary NIC, clearly not your fault. But really FreePBX? I will try each NIC. Unfortunately, what I’m doing now is DD’ing the LVM in a VM to a regular partition (Which has VMWare tools installed already.:(…), then I’m going to make an image of that, and move it to the physical server. Also a way to configure the NIC from the CLI would be nice to fix the log sending, but I’m sure thats something thats more “CentOS/RHEL” related, as I assume those distro’s do not include IFUP/IFDOWN or service network via the CLI either, tho I’ve never had to test.

@xrobau I found this link, which has the info I want. I’m just posting this for others:

That IS a deliberate error and thank you for telling me!
That means it was unable to figure out your disk layout. At that point you can push 'alt-f2' to get to a shell, then type 'dhclient eth0' to get an IP address, and then I need a complete copy of the /tmp directory.