Default Ring Time

I need to increase the default ring time for a sip extension. It seems that the default ring time is around 60 seconds at which time asterisk does a hang up via macro-hangupcall. I have tried the obvious things like setting “ring time” on the extension to 90 with vm enabled and setting “ring time default” in General Settings to 90. The longest ring time I can get is about 65 seconds. I have tried this on both a sip and zap extension.

Running Asterisk Version : Asterisk

  • Asterisk Source Version :
  • Zaptel Source Version :
  • Libpri Source Version : 1.4.7
  • Addons Source Version : 1.4.7

Any ideas would be appreciated.

Found this post searching on this issue.

freepbx general settings Ringtime Default

FreePBX works by changing general settings ringtime
FreePBX no joy

as no one has posted here, I will continue to search.

:)) Where is General Settings in the GUI? :slight_smile:
PBX Firmware: 3.211.63-6

This is now in Settings => Advanced Settings => Section “Dialplan and Operational” => Ringtime Default

and is by default only set to a puny 15 seconds!

I’ve opened a bug regarding the misleading (outdated probably?) tooltip:

Hm…I don’t tink I have the Advanced Setup option in Settings…

There’s only

Asterisk SIP Settings Extension Settings Music On Hold Voicemail Admin

PBX Firmware: 3.211.63-6
PBX Service Pack: