Declined outbound calls

Hi any, a n00b here :wink:
I installed the distro last week (Current Asterisk Version: 13.7.1 says the info page.) and configured 2 outgoing trunks.
I have each trunk with dial rule that says “0|X.” for one trunk, “9|X.” for the other so I can address the one or the other.
Calling between extensions works, outgoing (and incoming fwiw) calls go for the desired route but I have a problem with some numbers: if I call from any IP phone the number 9333xxxxxx I address the second trunk and call an italian mobile (all starts with “3”). It goes ok.
From the same phone I call 902xxxxxxx that is a land line (starts with “0”) I get “Declined”. Using “0” as prefix addresses the other trunk with same results, no calls to land lines.
I just want to be able to call any number from my extensions.
What should I debug? What am I missing? I followed other thread about outgoing routes but I think I miss something here…
Thanks for any hint

Maybe this helps. The WARNING lines are repeated hundreds of times before the last one here. There is some broken codec configuration?

[2016-05-25 17:24:39] WARNING[11260][C-00000014] chan_sip.c: Asked to transmit frame type ulaw, while native formats is (g729) read/write = ulaw/ulaw
[2016-05-25 17:24:39] WARNING[11260][C-00000014] chan_sip.c: Asked to transmit frame type ulaw, while native formats is (g729) read/write = ulaw/ulaw
[2016-05-25 17:24:39] WARNING[11260][C-00000014] chan_sip.c: Asked to transmit frame type ulaw, while native formats is (g729) read/write = ulaw/ulaw
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] app_dial.c: SIP/mgnet-eme-00000029 answered SIP/301-00000028
[2016-05-25 17:24:39] WARNING[11260][C-00000014] channel.c: No path to translate from SIP/mgnet-eme-00000029 to SIP/301-00000028
[2016-05-25 17:24:39] WARNING[11260][C-00000014] app_dial.c: Had to drop call because I couldn’t make SIP/301-00000028 compatible with SIP/mgnet-eme-00000029
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] app_macro.c: Spawn extension (macro-dialout-trunk, s, 23) exited non-zero on ‘SIP/301-00000028’ in macro ‘dialout-trunk’
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] pbx.c: Spawn extension (from-internal, 0030XXXXXXX, 6) exited non-zero on ‘SIP/301-00000028’
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] pbx.c: Executing [[email protected]:1] Macro(“SIP/301-00000028”, “hangupcall”) in new stack
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] pbx.c: Executing [[email protected]:1] GotoIf(“SIP/301-00000028”, “1?theend”) in new stack
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] pbx.c: Goto (macro-hangupcall,s,3)
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] pbx.c: Executing [[email protected]:3] ExecIf(“SIP/301-00000028”, “0?Set(CDR(recordingfile)=)”) in new stack
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] pbx.c: Executing [[email protected]:4] Hangup(“SIP/301-00000028”, “”) in new stack
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] app_macro.c: Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/301-00000028’ in macro ‘hangupcall’
[2016-05-25 17:24:39] VERBOSE[11260][C-00000014] pbx.c: Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/301-00000028’

Yup. You need to check with “mgnet” and see if they can help you with your codec choice.

This is probably going to be their answer.

Solved this minutes ago. My provider seems to accept the default set of codecs enabled in FreePBX for the calls towards mobile. Land lines behave differently, so disabling g729 in the list made the trick.
Thanks