DDNS Issues

I am running Freebx 16.0.26, with asterisk version 19.6.0. I am trying to use a dynamic IP enabled, but whenever my isp changes my address the system will not allow calls unless i go and change the external address in general sip settings. I have my router registered to my DDNS but the system never adjusts. Channel Sip settings have NAT yes, dynamic IP, 120 sec refresh.

What configuration mistake am I doing so that the system will router to the DDNS and not the external address? Any help would be appreciated.

This post was flagged by the community and is temporarily hidden.

Hi Duncanidaho,

I might be able to help. I have a PBX on a Dynamic IP and it is working fine.

I have an FQDN in the external address under sip general and in channel sip.

I use duckdns for my external IP lookup and I am not depending on my router to do it. Is your router updating quickly when your IP changes?

Are you using chan_sip or pjsip?

Are you using the DDNS section is system admin? I don’t bother with that.

What are your DNS servers?

Anything in /etc/hosts?

what about in /etc/asterisk/sip_nat.conf ?

Jeff

I tried to see if I could get a static IP from my ISP and they said they do not offer that. They suggested using a VPN for a static IP.

I am not that familiar with the technical side so i may have to request assistance from Freepbx.

Jeff

Thats for the note. Yes I do use ddns from sysadmin. I am not highly technical so I may need to hire someone to assist. My isp does not offer static IP and suggested vpn. I am using my router ddns option and it does register.

Hi,

You don’t need a static IP to get this to work.

Where are you getting your VoIP trunks from?

Can you post screenshots? (block out your IP address)

Post a screenshot of the General SIP settings and the SIP Legacy Settings. Chan_SIP.

I use two, one uses SIp and one uses pjsip.
Perhaps you can tell me how to set the General SIP Legacy and Channel Sip and I can attempt to have a similar setup. Ill have to find all the info you are looking for. Thanks

Here is my DDNS from sysadmin


Should I put my ddns address in the force IP?

Okay, so turn off the DDNS service.

Now from your router for the DDNS to work, you should be generating a public accessible FQDN?

myip.mydomain.com for example.

On the general sip settings, does it detect your proper public IP? If I get the correct public IP, I then put my FQDN in this field and save. Don’t click detect again.

Then on the sip legacy tab, I set it to this:

Anytime I reboot the system within 2 to 3 minutes, it knows my new IP address.

I have made the changes. The system still works, however, my external ISP has not changed. So I will monitor the external to see if it functions with a change of external IP. Thanks

Reboot the router. that’s the best way to test