Daylight Savings Time - Phones Not Updating

I’m in need of some help. We have over 600+ Cisco and Polycom phones and 99% of them, the time is incorrect. I have set the phones to use the NTP server of the phone server. Those are correct. I have also checked on the routers to see if the time is correct and it is. I cannot get the phones to update at all.


the phones solved most of our issues. a pain yes, but if you are using the end point manager it is not a killer of a job

I’ve tried that and it is still an hour behind. Any other suggestions? Plus, it’ll take forever rebooting 400 phones.

Do you have the following parameter set in your sip.cfg (Polycoms)?


I couldn’t find a spot in the administration GUI to enable daylight savings, but if you log into the polycom phones via their IP’s, there is an option to enable daylight savings under preferences.

Were these phones loaded from the endpoint manager? If so which one? Commercial or Open Source? The process is different for creating and editing basefile/template.

Under no circumstances should the parameters be changed on a phones web interface if that phone is provisioned via tftp/ftp or http.

You should not go into each phone directly to update the date/time settings.
First, your DHCP server needs to be giving out the time zone. Here are the relevant lines of my DHCP config (running on the FreePBX server):

option time-offset -28800; # Pacific Standard Time
option ntp-servers;

Next, if you are using the free version of endpoint manager, then you have to go into:

  1. Endpoint Configuration Manager
  2. Click on Product/Options Configuration Editor
  3. Choose the model of phone from the drop-down list. Click Select.
  4. Click on sip_3333 (or whatever digits you have for your version - I’m using Polycom 330’s)
    Look for the sntp section. Here is mine - it works for PST.
    After changing these values, you probably will need to go back into Endpoint Configuration Manager and choose the option at the bottom to rebuild configs for all the phones. Then, reboot the phones and cross your fingers!