Dashboard blank after power failure

Recent transformer blowout over holiday weekend. Freepbx Server came back up and phone are working, but when I browse to dashboard I get a blank page with red Error box. freepbx.log shows the following line :

[WARNING] (libraries/modulefunctions.legacy.php:7) - Depreciated Function module_getinfo detected in /var/www/html/admin/modules/cxpanel/functions.inc.php on line 67

I have tried reboots. I have tried some suggestions I have found in the forums such as download and install framework, but nothing seems to be working.

Also, I have a warm spare setup. After last nights copy that too has the same issue.

I have search Google and the FreePBX forums but nothing seems to be clearing this issue up.

Below is what I am seeing regardless of menu selected.

Here is the error showing up. I have been trying about every fwconsole command. Still getting blank dashboard with this error.

Anyone else have this?


Are any dependent modules disabled under module admin?

Are you at a place where you could restore to a backup that older than the date of the power outage?

The only modules disabled are:
“digiumaddoninstaller” Not Installed (Locally available)
“Zulu” Disable; Pending upgrade to
I don’t use either of these.

Our backup is a warm spare server. The day of the power failure the spare did not have this issue. Not thinking, when the backup ran that night it moved this problem to the spare also.

I am working on the spare to see if I can find a fix then apply that to the Main server.

All phones are working and I can get to the user control panel, but not the dashboard.

To confirm, you do not keep local historical backups at all?

When you run the module update search are there any updates available? What does it say for the system dashboard module?

Correct. We do not have historical backups. Figured with a warm spare that would be enough protection in the event the main went down.

There are updates, but not for the dashboard.


I’m not sure what is could be. I would guess maybe uninstall/reinstall the dashboard module or cxpanel, but that is an uneducated guess that I am not sure is possible, and I wouldn’t recommend that in production. Sorry I couldn’t be of more help. I do recommend that you keep some sort of incremental backup in addition to the warm spare in case something like this comes up again.

Some of the others, who are more knowledgeable may have an idea on where to go from here.

Thanks for trying to help. I feel it has something to do with the HTML pages as I can get to User Control Panel and all the menus show up for selecting… just nothing displays on the dashboard.

Solved it. turned out to be sipstation plugin. disable that and dashboard came up.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.