DAHDI VERSION change

A while back i had to install dahi ver 2.11.1 for a issue with the TE133 having IRQ interupts. Now I hear that the issue has been fixed and I want to make sure i am on the newest ver of dahdi but i dont know how to let freepbx take over dadhi again.

In module admin it shows

DAHDi Config 13.0.14 Stable Sangoma Technologies Corporation GPLv3+ Enabled

and it shows this when i run

[[email protected] ~]# dahdi_cfg -v
DAHDI Tools Version - 2.11.1

DAHDI Version: 2.11.1
Echo Canceller(s): HWEC
Configuration

SPAN 1: ESF/B8ZS Build-out: 0 db (CSU)/0-133 feet (DSX-1)
SPAN 2: ESF/B8ZS Build-out: 0 db (CSU)/0-133 feet (DSX-1)

48 channels to configure.

Setting echocan for channel 1 to none
Setting echocan for channel 2 to none
Setting echocan for channel 3 to none
Setting echocan for channel 4 to none
Setting echocan for channel 5 to none
Setting echocan for channel 6 to none
Setting echocan for channel 7 to none
Setting echocan for channel 8 to none
Setting echocan for channel 9 to none
Setting echocan for channel 10 to none
Setting echocan for channel 11 to none
Setting echocan for channel 12 to none
Setting echocan for channel 13 to none
Setting echocan for channel 14 to none
Setting echocan for channel 15 to none
Setting echocan for channel 16 to none
Setting echocan for channel 17 to none
Setting echocan for channel 18 to none
Setting echocan for channel 19 to none
Setting echocan for channel 20 to none
Setting echocan for channel 21 to none
Setting echocan for channel 22 to none
Setting echocan for channel 23 to none
Setting echocan for channel 24 to none
Setting echocan for channel 25 to none
Setting echocan for channel 26 to none
Setting echocan for channel 27 to none
Setting echocan for channel 28 to none
Setting echocan for channel 29 to none
Setting echocan for channel 30 to none
Setting echocan for channel 31 to none
Setting echocan for channel 32 to none
Setting echocan for channel 33 to none
Setting echocan for channel 34 to none
Setting echocan for channel 35 to none
Setting echocan for channel 36 to none
Setting echocan for channel 37 to none
Setting echocan for channel 38 to none
Setting echocan for channel 39 to none
Setting echocan for channel 40 to none
Setting echocan for channel 41 to none
Setting echocan for channel 42 to none
Setting echocan for channel 43 to none
Setting echocan for channel 44 to none
Setting echocan for channel 45 to none
Setting echocan for channel 46 to none
Setting echocan for channel 47 to none
Setting echocan for channel 48 to none
[[email protected] ~]#

so i know i am on dahdi 2.11.1 but what is 13.0.14 ???

13.0.14 is the version of the FreePBX DAHDI Config module.

What the newest ver of DAHDI ???

http://downloads.asterisk.org/pub/telephony/dahdi-linux-complete/?C=M;O=D

so 2.11.1

@dicko

Thanks for the reply. I though I was on the newest version but wasn’t sure.

I’m not sure if you’re running FreePBX Distro, but if you are, ‘yum update’ will get the latest Dahdi.

I am running freepbx 13 distro.

1 Like

Should be fine then. I do notice that you’re not setting any Echo Cancellation. In Dahdi Config, make sure that’s set to OSLEC.

Edit: Ignore me. HWEC is Hardware Echo Cancellation, and I missed that.

Lol I was like whattttttt lol yea I am using the Digium TE133 with EC. Works great. Actually I have two of them with two PRI.

Any everything works great. Running the paid EPM,system recordings, and sysadmin.

Only minor issue is when I set the post call recordings to my wav to MP3 script sometimes it does not record the call