DAHDI Trunk Issue

HI,

I am having some issues with an Astribank Bri and Xorcom and refusing to help due to the gateway being nearly 2 years old !

The Astribank is connected to a newly built FreePBX Distro running Asterisk 1.8

Everything seems to be working, the Astribank is USB and detected by Asterisk, all Spans are up and I have created a DAHDI Trunk.

When I make a call I am getting the following error

WARNING[1991]: channel.c:4747 ast_prod: Prodding channel ‘SIP/500-00000005’ failed
== Spawn extension (macro-dialout-trunk, s-NOANSWER, 4) exited non-zero on ‘SIP/500-00000005’ in macro ‘dialout-trunk’
== Spawn extension (from-internal, 07824880195, 5) exited non-zero on ‘SIP/500-00000005’
– Executing [[email protected]:1] Hangup(“SIP/500-00000005”, “”) in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/500-00000005’

I have no idea what this means, can anyone help.

At the moment I only have a ISDN 2e plugged into port 1. We are using a BT UK ISDN line.

Below is a copy of my chan_dahdi.conf file

;
; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]

language=en
context=from-zaptel
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes
busydetect=yes
busycount=10
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
callgroup=1
pickupgroup=1
immediate=no
nationalprefix=0

;faxdetect=both
faxdetect=incoming
;faxdetect=outgoing
;faxdetect=no

#include dahdi-channels.conf

group=1

#pridialplan=unknown

;Include AMP configs
#include chan_dahdi_additional.conf

; Autogenerated by /usr/sbin/dahdi_genconf on Thu May 2 12:04:28 2013
; If you edit this file and execute /usr/sbin/dahdi_genconf again,
; your manual changes will be LOST.
; Dahdi Channels Configurations (chan_dahdi.conf)
;
; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
;

; Span 1: XBUS-00/XPD-00 “Xorcom XPD [].1: BRI_TE” (MASTER)
group=0,11
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 1-2
context = default
#group = 63

; Span 2: XBUS-00/XPD-01 "Xorcom XPD [].2: BRI_TE"
group=0,12
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe_ptmp
channel => 4-5
context = default
group = 63

; Span 3: XBUS-00/XPD-02 "Xorcom XPD [].3: BRI_TE"
group=0,13
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe_ptmp
channel => 7-8
context = default
group = 63

; Span 4: XBUS-00/XPD-03 "Xorcom XPD [].4: BRI_TE"
group=0,14
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe_ptmp
channel => 10-11
context = default
group = 63

Many Thanks

After spending some time on Google looking this up I think the issue may be to do with the D channel on the ISDN lines.

Apparently this is a know bug within Asterisk going back several versions.

BT ( my Telco ) disables the D channel to save power, I have found this error when trying to make a call
– Called DAHDI/g0/07824880195
== Primary D-Channel on span 1 up
– Span 1: Channel 0/1 got hangup, cause 18
– Hungup ‘DAHDI/i1/07824880195-1’

Could this be related ?

Hi, thanks for the response

This model only has 4 BRI ports ( 8 lines ). is there something wrong with my config then for you to ask about PRI ports ?

The outbound route is set to use the DAHDI trunk that I set up although there is nothing in the really set other than DAHDI identifier is g0.

Also, not sure if it helps but I have been told that the BT ISDN lines are not Point to multi point hence why I changed Span 1 to be “signalling = bri_cpe”, I just haven’t change the others yet

Thanks…

Does your Astribank have a PRI port as well? I don’t think you need to worry about PRI messages since you’re using BRI’s.

Is your outbound route setup to correctly attempt to dial out over ZAP/DAHDI group 0?

Just noticed that after sitting idle for a while I also get this error

== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/500-00000005’
[2013-05-03 12:48:24] ERROR[1753]: chan_dahdi.c:14666 dahdi_pri_error: PRI Span: 1 Unable to receive TEI from network in state 3(Establish awaiting TEI)!

Thanks

[[email protected] ~]# dahdi_cfg -vv
DAHDI Tools Version - 2.6.1

DAHDI Version: 2.6.1
Echo Canceller(s): HWEC, OSLEC
Configuration

SPAN 1: CCS/ AMI Build-out: 0 db (CSU)/0-133 feet (DSX-1)
SPAN 2: CCS/ AMI Build-out: 0 db (CSU)/0-133 feet (DSX-1)
SPAN 3: CCS/ AMI Build-out: 0 db (CSU)/0-133 feet (DSX-1)
SPAN 4: CCS/ AMI Build-out: 0 db (CSU)/0-133 feet (DSX-1)

Channel map:

Channel 01: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 01)
Channel 02: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 02)
Channel 03: Hardware assisted D-channel (Default) (Echo Canceler: none) (Slaves: 03)
Channel 04: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 04)
Channel 05: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 05)
Channel 06: Hardware assisted D-channel (Default) (Echo Canceler: none) (Slaves: 06)
Channel 07: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 07)
Channel 08: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 08)
Channel 09: Hardware assisted D-channel (Default) (Echo Canceler: none) (Slaves: 09)
Channel 10: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 10)
Channel 11: Clear channel (Default) (Echo Canceler: oslec) (Slaves: 11)
Channel 12: Hardware assisted D-channel (Default) (Echo Canceler: none) (Slaves: 12)

12 channels to configure.

Setting echocan for channel 1 to oslec
Setting echocan for channel 2 to oslec
Setting echocan for channel 3 to none
Setting echocan for channel 4 to oslec
Setting echocan for channel 5 to oslec
Setting echocan for channel 6 to none
Setting echocan for channel 7 to oslec
Setting echocan for channel 8 to oslec
Setting echocan for channel 9 to none
Setting echocan for channel 10 to oslec
Setting echocan for channel 11 to oslec
Setting echocan for channel 12 to none

Any help…

On my BT lines I have DDI’s but I am using

signalling = bri_cpe_ptmp

As the signalling type

It’s all working now, I decided to repost in the Disto forum as this issue is more to do with asterisk than FreePBX. For info on how it was resolved please refer to the post n the Distro forum.

Thanks…